dMRI Extension Files -- Where do they end up?

I’ve been trying to complete the whitematteranalysis, but stuck on the last step as I cannot locate the SlicerDMRI extension files on my Ubuntu box.

The step I’m stuck on:

8. Fiber tract diffusion measurements ./FiberClustering/SeparatedClusters/tracts_left_hemisphere/ ./DiffusionMeasurements/left_hemisphere_clusters.csv /Applications/ ./FiberClustering/SeparatedClusters/tracts_right_hemisphere/ ./DiffusionMeasurements/right_hemisphere_clusters.csv /Applications/ ./FiberClustering/SeparatedClusters/tracts_commissural/ ./DiffusionMeasurements/commissural_clusters.csv /Applications/

Anyone know where the I can find FiberTractMeasurements with the 3D Slicer linux installation?

Hi @mgc26

Here you are using the cli module path under a Mac OS, which is for demonstration in the tutorial you followed.

For Linux, you will need to install both 3D slicer and SlicerDMRI extension. See here for SlicerDMRI installation instructions:

Then, you should be find the module under your 3D Slicer folder, like this: Extensions-XXX/SlicerDMRI/lib/Slicer-4.XX/cli-modules/FiberTractMeasurements

Please let me know how it works for you.

PS: for any further issues related to WMA, you can directly create an issue in the WMA repository.

Thanks for getting back to me, Fan.
I do have 3D Slicer installed as well as SlicerDMRI per the instructions. I was able to run the WMA whole tutorial up through the last step.
The issue is that in the Linux 3D Slicer directory there is no extensions folder containing SlicerDMRI.
In my 3D Slicer GUI, I am able to see that SlicerDMRI is installed and can use it. The installation appears to have worked just fine.
However, when I try to do the WMA tutorial at the CLI there SlicerDMRI extension files don’t exist in the 3D Slicer application directory.

Hopefully that clarifies the issue I’ve run in to.

Have you tried to search within the Slicer folder to see if you can find FiberTractMeasurements? Unfortunately, I don’t have a linux machine to check the path.

Another way, if you run the FiberTractMeasurements using GUI, in the “log message” (right bottom red), you can see how the cli is being called. From there, you will see the path of the cli module.


Hi Fan,
Thanks for your reply. I used your log message trick and it did indicate how the CLI is being called, but it appears to be in a hidden location:


Unfortunately, the script to run the measurements does not work as the .config folder is ‘hidden’ in Ubuntu. Thus, it appears Slicer3D stores the extension cli-modules in a hidden config file.

As a workaround, I tried downloading the DMRI source code from Github and tried to source FiberTractMeasurements directly


Now, I’m getting an error on permissions:

sh: 1: /home/**/SlicerDMRI-master/Modules/CLI/FiberTractMeasurements: Permission denied

I’ve tried to unlock the files using chmod +x * but to no avail.

Any suggestions beyond this?

For the FiberTractMeasurements, can you try to run “/home/**/.config/NA-MIC/Extensions-29402/SlicerDMRI/lib/Slicer-4.11/cli-modules/FiberTractMeasurements -h” from your terminal and see if it works?

Not sure why it does not work in the script. Perhaps also try adding parentheses to the module path “/home/**/.config/NA-MIC/Extensions-29402/SlicerDMRI/lib/Slicer-4.11/cli-modules/FiberTractMeasurements”

Directly from the source code should not work. You will need to compile in order to have the binary executable file.


Hi Fan – thanks for your continued support.

Unfortunately, it appears that the script still cannot find FiberTractMeasurements with adding “-h” or putting the command in parentheses as you suggested.

I was able to generate the measurements using the GUI, so the dMRI module works. Seems the issue here is that when 3D Slicer installs extensions into the hidden .config folder they are not accessible with the terminal call supplied in the WMA tutorial. The remainder of the tutorial executed perfectly…