Edited segment is undone when the next segment is edited

Operating system windows 11
Slicer version: 5.2.2
Expected behavior: Want to protect and preserve all segmentation edits
Actual behavior: Editing a subsequent or new segment and using an operation like fill value or a logical operation works fine for the segment being edited but the greyscale information from the previously edited segment. reappears. My previous work is undone What is causing this?

I’m not sure what grayscale information you are referring to. Could you clarify, maybe attach a few illustrative screenshots?

Hello, Andrus.

The volume is one which we want to segment into Air (-1000 Hu), water (0 Hu) and bone. The bone is to remain unedited.

I began by transforming the background and internal voids to -1000 Hu. (Air)


I then turned off the segment layer and moved on to transforming the non-bone elements of the head to 0 Hu (water).

I bracket this process to come as close to the bone as possible and to preserve delicate, thin bones in the sinus and temporal regions.

The first mask is bracketed at -500 to 50 Hu.

Crysttal Test 6-1-23 Image 3.png

I next used “mask volume” to apply a “fill value” of 0 Hu inside the mask.

The “fill value” worked. But…

Crysttal Test 6-1-23 Image 5.png

…the material I transformed in the previous segmentation has returned. Dang!

Hoping to fix the problem I went back to the first step to transform the background and voids again to -1000 Hu. And…

… it worked but the transformation I did inside the head in the second segmentation was undone.

I seem to be stuck in a loop. I would like to preserve my work in the segments segments as I go and then output the resulting edited volume in an imagestack for further editing in another application

Any help is appreciated. I am relatively new to Slicer and have much to learn.

Thanks for taking a look at this.