Endoscopy - camera not moving along path?

OK, I’m pretty sure this is pilot error, but I’ve tried to do a fly through on a couple of datasets and I’m not sure what I’m doing wrong. To make a fly though, I am:

  1. Load example dataset (CTACardio)
  2. Volume render
  3. Pick preset to make it look snazzy
  4. Place 3-4 fiducials to define path
  5. Go to endoscopy module
  6. Pick my fiducial list, leave camera as “Default scene camera” (pretty sure this is where I’m going wrong)
  7. Hit “Create path”

When I hit “Play” or drag through the frames, the camera view rotates and pans like it’s following the path, but the camera doesn’t travel along the path - it maintains its original viewpoint. Let me know if this isn’t clear and I can post a video. (I think.)

I did a quick look through the docs and tutorials on YouTube for a tutorial on the Endoscopy module - can someone point me in the right direction?

Many thanks!!

-Hollister

Hmm, I tried those steps and things looked fine. What version of Slicer and I assume you did this from a fresh start of Slicer? You should see a curved line passing through your fiducials. Yes, a movie might help troubleshoot.

Yes, this is from a fresh start. I’m using a nightly from early January (4.9, probably Jan 3 or so). It’s possible I just don’t understand what the endoscopy view is supposed to look like - my understanding is that the camera view would follow the path defined by the fiducials (I do see the curved line). I’ve shared a screen capture in a Dropbox folder (link below). Let me know if you can’t play the video.

Any ideas?

Thanks!!!

-Hollister

Oh yeah, MacOS 10.12.6. Downloading more recent nightly now to try.

Latest nightly does the same thing, as does 4.8.1. (GPU volume rendering on MacOS is kinda wonky on latest nightly, I think I already saw something about that come across a few days ago.)

It’s gotta be something I’m doing wrong.

Yes, the volume rendering back end has changed in the current nightlies and there could be a clipping plane problem or similar.

Maybe to narrow things down you could try turning off volume rendering and instead make a simple bone segmentation and confirm that the camera is behaving correctly.

On my local mac build of the trunk endoscopy is definitely working and looks good with CPU volume rendering but there are some artifacts with GPU.

image

I made a quick video of the steps I’m doing from startup to hitting “Play” and uploaded it to the dropbox link below (same as before), called “Pilot_error.mov”. Could you take a quick look at it and let me know what I’m doing wrong?

Thank you very much!

-Hollister

Works well for me, too. It may help if you reset the camera’s clipping range by zooming in/out of the 3D view after the animation is started.

OK, I think I figured out my misunderstandings. First off, the scene I was trying to do a fly through of initially (before going to CTACardio to just figure out how it worked) wound up with like 5 Default Cameras, so I have no idea which one was actually being acted on.

Zooming in and out to reset the clipping range was extremely useful - thank you very much for that tip.

Thanks Steve and Andras for your responses - very helpful, as always!

-Hollister