Error after installing radiomics


everytime I try to run Slicer 3D an error table shows up image

it started after I installed Radiomics, which I had to do offline from a file(downloaded from, and everytime I run Radiomics module, Slicer crashes… can anyone help, please?

I have tried reinstalling Slicer for the newest version, but no change

It looks like Slicer tries to load a compiled module (which can be the C extensions of PyRadiomics or C code include in pyyaml package), but is unable to do so and crashes. Is there a specific reason you need to install PyRadiomics offline? Maybe there is a version mismatch, does the version of the offline file match your slicer version?

yes, the reason I can’t do it online is because Slicer has problems connecting (it does not load extensions at all or it shows a connection problem) …could this be caused from changing the proxy settings? this is the latest change I have made

I have a matching version, I turned off proxy settings so now I can install it online, but the Runtime error still shows up, now together with

Traceback (most recent call last):
File “C:/Users/Diana/AppData/Roaming/NA-MIC/Extensions-27158/SlicerRadiomics/lib/Slicer-4.9/qt-scripted-modules/”, line 576, in _onStatus
if self._cli_running:
AttributeError: SlicerRadiomicsLogic instance has no attribute ‘_cli_running’

any ideas, please?