slicerradiomics error

When using Slicer Radiomics in 4.13 version I get this error:

RadiomicsCLI standard error:

Traceback (most recent call last):
File “C:/Users/Yi�it/AppData/Roaming/NA-MIC/Extensions-29434/SlicerRadiomics/lib/Slicer-4.13/cli-modules/SlicerRadiomicsCLI.py”, line 7, in
from radiomics.scripts import parse_args
File “C:\Users\Yi�it\AppData\Roaming\NA-MIC\Extensions-29434\SlicerRadiomics\Lib\site-packages\radiomics_init_.py”, line 15, in
from . import imageoperations
File “C:\Users\Yi�it\AppData\Roaming\NA-MIC\Extensions-29434\SlicerRadiomics\Lib\site-packages\radiomics\imageoperations.py”, line 7, in
import SimpleITK as sitk
ModuleNotFoundError: No module named ‘SimpleITK’

I will be glad if you help me

As indicated in the download page currently preview (v4.13 series) is unstable, and may not work as intended. Your best option is to use the stable (v4.11-20200930) until changes to preview is finished.

I tried it on version 4.11 today but got a similar error again:

RadiomicsCLI standard error:

Traceback (most recent call last):
File “C:/Users/Yi�it/AppData/Roaming/NA-MIC/Extensions-29402/SlicerRadiomics/lib/Slicer-4.11/cli-modules/SlicerRadiomicsCLI.py”, line 7, in
from radiomics.scripts import parse_args
File “C:\Users\Yi�it\AppData\Roaming\NA-MIC\Extensions-29402\SlicerRadiomics\Lib\site-packages\radiomics_init_.py”, line 15, in
from . import imageoperations
File “C:\Users\Yi�it\AppData\Roaming\NA-MIC\Extensions-29402\SlicerRadiomics\Lib\site-packages\radiomics\imageoperations.py”, line 6, in
import pywt
ModuleNotFoundError: No module named ‘pywt’

Looks like things are getting confused by a special (non US) character in your home directory path. Try installing Slicer in a different path, like c:\Slicer or similar.

Well I don’t think @firatoz can. That’s the extension (not the application), which goes directly into the AppData under user folder (which has the special character), when extension manager is used.

@firatoz you can follow this instructions, and download the Radiomics extension for your specific slicer version manually and then to a folder that that doesn’t include any non-ascii characters: https://www.slicer.org/wiki/Documentation/4.3/SlicerApplication/ExtensionsManager#How_to_manually_install_an_extension_.3F

@lassoan @jcfr is this an Slicer issue or Radiomics extension issue?

I downloaded the slicer radiomics. " lib / Slicer-X.Y / cli-modules and lib / Slicer-X.Y / qt-scripted-modules" these files exist but there is no file " lib / Slicer-X.Y / qt-loadable-modules" that I need to copy into module settings.

There might not be one. Go ahead and restart Slicer and try again.

You are right, this is perhaps something we should fix. On mac the extensions go into the application installation folder, which is cleaner I would say.

Anyway, perhaps @firatoz can move the extension folder and then edit the paths in the Application Settings -> Modules paths to match.

@muratmaga I tried many times in versions 4.13 and 4.11, unfortunately I cannot install it manually.

Can you try what @pieper suggested?

Install via extension mechanism, then move the folder out of problematic path (e.g., to something like C:/Radiomics or something), and then modify the module paths from application settings accordingly?

i changed the location of the extension to C: / Radiomics but it still didn’t work. I have tried it on other computers, unfortunately I cannot run Radiomics. I wonder if this could be a software bug that needs to be fixed

Can you send the log file from the instance where you have it in c:/radiomics?

This is a known issue, you need to manually install two Python packages (copy-paste two lines of code into the Python console) - see details here. It is expected to be fixed very soon.

Note that special characters in paths should not be an issue if you use latest stable Slicer release and Windows 10 Version 1903 (May 2019 Update) or later (see documentation).