Extension download issues in govcloud

I have slicer installed on a Windows ec2 instance in govcloud. I’ve tried a few versions (5.2.1, 5.2.2, 5.3.0).

If I attempt to install from extensions manager, I receive “Failed downloading: https://slicer-packages.kitware.com/api/v1/file/...../download”. I’m trying to install the MONAILabel plugin, but the issue I’m running into happens with any extension install.

I tried using the extensions catalog website (@KitwareMedical/slicer-extensions-webapp) provided in this thread: New release 5.0.3, unable to download extension. I’m able to download and then install from file, but the plugin isn’t findable in slicer (I’ve done a number of restarts). I still see MONALabel as installed in extensions manager, but if I try to uninstall I receive: “Failed to open extensions settings file C:/apps/bin/…/NA-MIC/Slicer-31317.ini” (I’ve also tried 30893.ini).

Hoping for any tips on what to try next.

Be sure to follow these instructons:


If that;s not working probably you should start fresh, maybe on a fresh VM instance and follow these instructions:

Check the log files and see where the first error messages come up. I’ve never used govcloud but it’s probably locked down in some way that will require you to do some workarounds.