Failed to save a scene to external ExFAT usb volume on MacOS


Version 5.4.0, I was not able to save a scene successfully to an external usb volume on MacOS (works on windows though). Error message below,

vtkMRMLVolumeArchetypeStorageNode::WriteDataInternal: Error renaming file to /Volumes/USB1/test1/._t1.nii.gz, renameReturn = -1
bool qSlicerCoreIOManager::saveNodes(qSlicerIO::IOFileType, const qSlicerIO::IOProperties &, vtkMRMLMessageCollection *, vtkMRMLScene *) error: Saving failed with all writers found for file "/Volumes/USB1/test1/t1.nii.gz" of type "VolumeFile"
void qSlicerSaveDataDialogPrivate::updateStatusIconFromMessageCollection(int, vtkMRMLMessageCollection *, bool) Data save error: "- Error: Error renaming file to /Volumes/USB1/test1/._t1.nii.gz, renameReturn = -1\n- Error: Cannot write data file: /Volumes/USB1/test1/t1.nii.gz.\n"

Anyone knows why?

Thank you!

By default, node names are used as file names. It seems that your node name has some special characters or starts or ends with a space, etc. that is not a valid filename on the file system you are trying to save. I would recommend to rename the node.

I simply named the node as t1 but the error message shows it somehow tried to rename/save the file to ._t1 or going through this process. It only happened in macos but worked fine in windows.

Make sure the node name does not start or end with a space. It may be hard to see that when the node name is displayed, but more visible when you are editing the node name.