Fill between slices horizontally

Currently I am trying to segment the cartilages and meniscus. I have already created segments horizontally. however when I tried to fill between slices they are not connecting?

Does anyone knows why?

I really need this to work. I did once before it worked just fine but today i try again its not working

You can fill slices only along one axis at a time. If you painted slices in different orientations then you need to fill between them in several steps. In each step, you show only those segments that have the same orientation and hide all the others (that are in a different orientation or already filled), and then apply “Fill between slices”. Make sure to enable overlapping segments to preserve the segments that are hidden.

If doing this in several steps is not convenient then you may also try methods that work with arbitrarily placed seed regions, such as “Grow from seeds”.

Let us know how it works for you.

Hi I have only sliced in one direction as shown in the picture

The fill between option is not connecting the gaps between each slices for some reason and i do not know why

I even tried to start a new segmentation for testing and I just did 2 slices from the sagittal view. And tried the fill between, however it is still not connecting thoes 2 slices

Filling only happens between standalone slices (that have completely empty neighbors). Nothing is filled in the image above anymore, because none of the slices look like standalone (there are 2 or more neighbor non-empty slices).

Ok got it. So to make the filling happens how many empty slices should be between each slice. I will go try it again and update you

Thank you

Each slice that you need to fill between has to be a single slice with at least one empty slice on each side.

If two or more neighbor slices are segmented then it will be considered as a complete 3D object and will not be connected to other slices on either side.

Hi I have re-segmented as shown (1) . However when i try fill in between slices it is not working and I am not sure why, the gaps between each slices are not connecting

(1)
(2)

Thank you very much for your help

Sorry for all the troubles. It seems that you segment on oblique slices (you can see that from the warning icon displayed next to the segmentation node selector). This way when you paint on one slice, you actually paint on several slices of the segmentation. Unfortunately, fill between slices algorithm always works on the original slices, cannot work on oblique slices.

You can either try Grow from seeds effect (that does not require this strict slice-by-slice painting), or you can resample the segmentation geometry with rotated axes.

Knee MRI segmentation is hard, but it should be possible to establish a good segmentation workflow.

@carlp I saw some amazingly high quality knee segmentations from you. Could you help with some advice here? Or - it’s soon time for Christmas, so maybe I can ask such things - could you create a screencast video that shows how you segment a knee?

1 Like

Hi Andras,

thank you very much. I will explore the grow from seeds effect options as well as rotated axes. But may I know how does the rotated axes work?

Also the screencast will be insanely helpful as i am trying to obtain a geometry for a FEA analysis, meaning that i would require a a decent quality of the knee segmentation.

Thank you

See this page for more information on segmentation on oblique slices: https://lassoan.github.io/SlicerSegmentationRecipes/ObliqueSliceSegmentation/

1 Like

Thank you. I will let you know how I get on. Hope you and your family have a nice Christmas

1 Like

Hi currently I am just segmenting each slice as I only need the overall geometry and i will redraw the structure in solidworks. However I ran into a problem where if i paint something in one slice it affects its direct neighbour slice,


This is normal when you segment on oblique (non-axis oriented) slices. See this page for more details: https://lassoan.github.io/SlicerSegmentationRecipes/ObliqueSliceSegmentation/

HI,
i have tried the grow from seed it indeed works faster but i want to ask why is my segmentation coarse, as shown below. Thank you

I think that is because of low resolution.

Few thigns that come to my mind that you can do is,

  1. Oversample (from segment editor, specify geometry option)
  2. reslice it useing Crop volume (Setting spacing scale to <1.0x )
  3. Apply smoothing

I prefer reslicing because oversample for me takes too much power.

ok got it thank you. i will try another CT scan see if it has a better resolution.

Hi I am currently trying to use the oversampling option, I want to ask what does it actually achieve?
image
my model turned like this after

Thank you.

Hope you had a lovely holiday

You can see in this post.

Greetings and thanks for the kind words =]

You can find several video demonstrations of our knee segmentation software using AI on nordiccad.com