Green horizontal lines appear in Slicer-4.10.2 at startup

Operating system: Windows 10 i7
Slicer version: 4.10.2

Hi all

I have been using slicer with my pc for quite sometime. However, out of the blue, the following happen to my slicer as shown in the image below. I had tried reinstalling it but it does not work. Do you have any idea what is happening?

Thank you

This looks like a graphics card driver update broke OpenGL rendering on your computer.

What graphics card do you have in the computer and what is the driver version?
Is the behavior the same with latest Slicer Preview Release?
Are other VTK-based applications, such as ParaView, have similar rendering issues?

Hi

I am using GTX 1660 Ti v446.14. I was working with this graphic card all these while and it was working perfectly fine with slicer. It just happen to be crash one day when i was loading dicom files. The next moment when i restarted slicer, this happened.

Paraview is working perfectly fine as well.

Yes, it has the same behavior with the latest preview release.

Slicer crash may corrupt the application settings file. The strange rendering artifacts is not a typical symptom, but you can give it a try and run Slicer with default settings - see here: https://www.slicer.org/wiki/Documentation/Nightly/Developers/Tutorials/Troubleshooting#Instruction_for_Windows (and delete application settings if that solves the problem).

Another possibility that Windows determined that the crash was due to to application compatibility issue and decided to run Slicer in some compatibility mode. Right-click on SlicerApp-real.exe and play around with settings in “Compatibility” tab.

Is this a laptop with NVidia Optimus? Do you have multiple monitors connected? Any of the monitors are HiDPI?

1 Like

The link you had provided does not work for this case. However, one of the error i had found in event view is the following:

Faulting application name: SlicerApp-real.exe, version: 0.0.0.0, time stamp: 0x5cddc587
Faulting module name: Qt5Gui.dll, version: 5.10.1.0, time stamp: 0x5a7c816f
Exception code: 0xc0000005
Fault offset: 0x0000000000313186
Faulting process id: 0x3544
Faulting application start time: 0x01d6377bd7b23133
Faulting application path: C:\Program Files\Slicer 4.10.2\bin\SlicerApp-real.exe
Faulting module path: C:\Program Files\Slicer 4.10.2\bin\Qt5Gui.dll
Report Id: 03c680aa-d127-4154-8143-70b34e134720
Faulting package full name:
Faulting package-relative application ID:

Faulting application name: SlicerApp-real.exe, version: 0.0.0.0, time stamp: 0x5cddc587
Faulting module name: ig9icd64.dll, version: 26.20.100.8141, time stamp: 0x5e91eea6
Exception code: 0xc0000005
Fault offset: 0x000000000002a7e2
Faulting process id: 0x265c
Faulting application start time: 0x01d625d9f1aac289
Faulting application path: C:\Program Files\Slicer 4.10.2\bin\SlicerApp-real.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_0dd7d9c16d9ad9c5\ig9icd64.dll
Report Id: c2874064-8295-43b0-890e-954552200449
Faulting package full name:
Faulting package-relative application ID:

I tried playing around with the compatibility tab and the following happened:
When i tried to “Run compatibility troubleshooter” -> “Try recommended settings” -> “Test the program”
I got the following error:

The code execution cannot proceed because CTKWidgets.dll was not found. Reinstalling the program may fix this problem"

However, i have tried reinstalling Slicer a couple of times and it does not work.

Seems like the drop down window is fine but not the main window.

Yes it has Nvidia Optimus. I have multiple monitors but i did test it without multiple monitors as well… None of these monitors are HiDPI. I have been using this system for quite sometime and had no issue previously.

Could you try running Slicer on the NVidia and on the Intel Integrated Graphics card?

Does deleting all Slicer*.ini files help?

Do you have the issue when the application window is not maximized?

Could you post a screenshot taken of latest Slicer Preview Release?

Thank you Iassoan! It works after I delete ALL the .ini files and rename NA-MIC to NA-MIC-backup

It’s back to normal now.

Thank you for your patience!

1 Like

I have the same problem. I solve the problem by stopping my Intel HD Graphics 630 driver and only using the NVIDIA driver.

Regards.