Slicer 4.10.2 Not responding on Windows 10 (blank screen on older laptop)

Hi All,

After having used Slicer 4.8.1 on Mac OS X for about 2 years, I recently had the need to move to Windows 10. I choose to download the latest version 4.10.2, however, as soon as I run it, it crash displaying a blank white screen and not responding.
Is there any log file I can check? Am I ignoring any incompatibility between Windows 10 and Slicer?


Hi - It should work fine on windows 10 (it does for me). The log files are stored in your windows user account under AppData/Local/Temp/Slicer. It might be something to do with your graphics driver. You could also try the preview build.

Hi Steve,

Thanks for your reply. This is my log.

*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Session start time .......: 2019-07-09 08:49:55*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Slicer version ...........: 4.10.2 (revision 28257) win-amd64 - installed release*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Operating system .........: Windows /  Professional /  (Build 9200) - 64-bit*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Memory ...................: 32611 MB physical, 37475 MB virtual*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - CPU ......................: GenuineIntel , 16 cores, 16 logical processors*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - VTK configuration ........: OpenGL2 rendering, TBB threading*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Developer mode enabled ...: no*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Prefer executable CLI ....: yes*
*[DEBUG][Qt] 09.07.2019 08:49:55 [] (unknown:0) - Additional module paths ..: (none)*
*[DEBUG][Python] 09.07.2019 08:50:01 [Python] (C:\Program Files\Slicer 4.10.2\lib\Slicer-4.10\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: Annotations*
*[DEBUG][Python] 09.07.2019 08:50:02 [Python] (C:\Program Files\Slicer 4.10.2\lib\Slicer-4.10\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: SegmentEditor*
*[DEBUG][Python] 09.07.2019 08:50:02 [Python] (C:\Program Files\Slicer 4.10.2\lib\Slicer-4.10\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: SegmentStatistics*
*[DEBUG][Qt] 09.07.2019 08:50:02 [] (unknown:0) - Switch to module:  "Welcome"*

However, in switching to “Welcome” module it actually turns to a blank white screen and, if I click on it, it goes to “Not Responding” status and it doesn’t append any log in the file.
I tried with the preview release, but the behaviour is the same.

If it can help, my graphics card is Intel(R) UHD Graphics 630 and these are the drivers:

  • igdumdim64.dll
  • igd10iumd64.dll
  • igd10iumd64.dll
  • igd12umd64.dll

Is there any other check I could do?

Try latest Preview release of Slicer and these instructions: Slicer nightly version does not launch on windows and let us know what you find.

I’ve erased Slicer.ini and Slicer-NNN.ini files and downloaded the latest preview. At first run of Slicer, it doesn’t crash. However, at this stage Slice put new Slicer.ini and Slicer-NNN.ini back and if I try to open it again it crashes. Basically, I need to erase those files to be able to run it again.

I haven’t tried to install Paraview yet. If you think it could help in understanding the issue, I can do that.

I’ve installed ParaView 5.7.0 anyway and it works properly.

Do you have multiple monitors connected? Have you installed any extensions or Python packages? Is there any error/warning in the application log? (you can find log of previous sessions in menu: Help / Report a bug - then select a session in the listbox).

Yes, actually I have and I’ve just noticed that if I keep it on my main monitor I don’t need to erase .ini files to run it again. Is there anyway a way around that?

Not yet, but I possibly will.

All the logs look like the one I pasted above. When I tried to access the Extension Manager from the second monitor a ’ [DEBUG][Qt] 09.07.2019 13:35:37 [] (unknown:0) - Switch to module: “” ’ has been appended.

This is very useful hint. Most probably Qt has issues restoring Slicer main window size. Probably you have somewhat unusual configuration, such as one monitor is HiDPI and the other is not; or their size is very different. Could you give us some information about resolution and physical size of your displays?

As a workaround, you can disable saving/restoring of window position in menu: Edit / Application settings / Appearance / Save user interface size and position on exit.

The main one is 1920x1080 23’’; the second is 1680x1050 22’’. I’m happy to give more details, if needed.

This will definitely help.

Thank you very much for your help.

I’ve been having the same problem, it does seem to be an issue with one of my monitors (I have 3, all 1920x1080). Slic3r 1.3.0, windows 10.
On my main monitor, everything works fine. If the window opens on the right monitor I get “Not Responding”. Haven’t tried the left one, thats my netflix monitor :slight_smile:
I’ve been using slic3r for a long time, but this issue seems new to me. I will disable saving/restoring of window position for now, but hopefully it can get resolved at some point.

Which application are you referring to: slic3r or 3D Slicer?

Sorry this forum is for 3D Slicer not for Slic3r.

Hi there. I am having exactly the same issue with preview release 4.13.0 2021-05-19. after starting the program, it appears a blank white screen and do no more.

I have installed the program in Windows 10 home version 1709 (64 bit), in my laptop dell inspiron n411z.

But, what is even more curious. All the menus, toolboxes and modules are there, just that they do not appear on screen. I noticed it when started clicking on the blank white screen. have a look in the attached image.

What could I check to solve this? regards

Hi @Andres the latest Slicer Preview requires a newer set of hardware. Generally Slicer works well on hardware that is 5 years or newer. See

Unfortunately I suspect your computer which is originally from 2011 to be too old to run Slicer. At this point that would make it 10 years old which is twice as old as what is recommended to use the latest Slicer version.

Do you have access to a newer computer to use the latest Slicer versions?

Have you tried Slicer 4.11.20210226 ?

Hi James.

I have updated my post. As you can see, all is there but simply do not appear on screen. Do you think I still need to install the older version? or is maybe something else? Unfortunately right now I do not have access to a newer computer and I really need this latest Slicer release since as far as I know this is the one that can open scanco CT files (.isq).

Looking forward to your reply

Until you can get a more recent computer, you can run Slicer on the cloud and access it from your web browser. There are computers that can run the latest version of Slicer and available to use for free, for anyone.

See link that opens Slicer on Binder (a free Jupyter notebook hosting provider) here. This uses a Jupyter notebook image that was created a year ago, so it cannot open .isq files. However, you can build a new docker image by updating this dockerfile.

If you don’t know and don’t want to learn using docker then you can find other cloud providers that allow accessing a regular desktop interface where you can download and install the latest Slicer version.

If your usage need is short-term, we are hosting a cloud instance based on the latest stable version of Slicer (along with a bunch of other extensions). If that works for you, please sign up here:

and then I can create an account for you and send you the instructions.
This is only available until end of June.


Hi Muratmaga. Thanks for your support. I have solved the issue by installing the software in a newer laptop. Thanks anyway.

1 Like

Hi everyone, I had the same issue. When I open 3D Slicer, after the flashes loading all the modules and poping up the Slicer interface, the window white out and title shows “3D Slicer 4.11.20210226 (Not Responding)” no matter how long I wait. I have tried uninstall it, clear all the Slicer reigistries in “regedit” and reinstall the version 4.11 or 4.13. However the problem still exist.

It looks like the multiple monitor issue as mentioned above. When I disable a monitor and use only one, the 3D Slicer can open property. Then if I connect back to dual monitor, the already-opened 3D Slicer works fine. Not sure how to solve the issue better