Grow From Seeds Not Working

Hi everyone,

I have a question about the “Grow from seeds” effect in Segment Editor. I have been using it pretty seamlessly in the past, but this morning when I tried to use it, its effect is to remove everything I have painted. Furthermore, I even tried to paint within this effect hoping for function to auto-update - as it normally does - however there was no effect of using the paint function.

Attached are two screenshots depicting the problem. After initializing the “Grow from seeds”, the painted colours become more dull, implying that they will be, and are, removed when the effect is applied, and the result is a blank slate after I click “Apply”.

I was having trouble with crashing this morning so I downloaded the 4.11.0 version (28391) but the problem with “Grow from seeds” is occurred on both this version and the 4.10.2 version (28257).

Thanks in advance!

It is hard to guess from this much information, but you can try these:

  • Make sure “Masking” settings are set to default (Editable area: Everywhere; Editable intensity range: unchecked; Overwrite other segments: All segments).
  • Make sure that other auto-complete effects (Fill intersection between slices, Watershed) are not active

Thanks for the quick reply!

I double-checked these settings and they were set just as you mentioned. I gathered it would be a bit of a guessing game with the limited information. I can provide additional details if necessary, but I am not sure what else would be helpful. I was more wondering if this was a recurring issue that had an easy fix.

I’ll let you know if I have a breakthrough.

Is there any warning or error in the application log?

Can you share the scene file?

You can try creating a new scene and load just the volume and segmentation files and see if things get back to normal then.

From what I can tell, there is no error in the application log.

A bit of a strange progression: I had temporarily given up on that file and just decided to move on. I started another one, periodically making sure my “Grow from seeds” function worked, which it did. Anyway, after not attempting the “Grow from seeds” following a substantial amount of painting, I was done and ready to get my 3D model. Upon initializing the “Grow from seeds”, the exact same thing happened - it wanted to remove everything!

After trying a handful of things to no avail, I created a new scene and loaded the volume and segmentation files (as you suggested), and it worked. This confused me, as I was pretty sure I tried this with the other file yesterday. Sure enough I tried again with the other file and it did not work with this one.

In regards to sharing the scene file, did you want me to share it here? I was under the impression that I could only share jpg, jpeg, png, and gif files.

I hope this is not some dumb mistake on my part - or maybe it would be more convenient if it was. As always, I appreciate the help.

You can upload to dropbox/onedrive/gdrive and post the link here.

Thank you! My apologies, it’s my first time here.

Here is the link:

It asked for a verification code. Please either send the verification code or allow access without verification.

Thanks so much for you patience, Andras. Here’s a Dropbox link, this should work a lot better:

Sorry, it took me a while to get to this. I’ve checked the scene that you shared and interestingly there was a 0.000003 difference in image origin position (due to numerical inaccuracy? saving of values to file?), which tripped a geometry consistency check.

I’ve fixed the check now, so Grow from seeds should work correctly in Slicer Preview Release downloaded tomorrow or later.

Thanks again for reporting the issue, it was very helpful.