How to get airways using LungCTAnalyzer

This question is a continuation to an issue I posted on github. I am posting follow-up here.

I performed the steps as suggested. However, as can be seen in the second picture. Somehow the lung lobes and airways are being mixed up.

The ONLY blue colored segmentation includes both Lung lobes + Airways + Bronchus – As seen in the picture below.

However when I deselect the segmentation labeled as airway, this is what I see

Thanks for any help

That data is incorrectly formatted (the body is upside down). This should never happen for dicom data or any data that’s been consistently processed. Check the pipeline from scanner to slicer to correct any processing steps that might have introduced this issue. We take coordinate system issues very seriously so if your research indicates there might be a bug in Slicer please report all the details so it can be investigated.

Thanks for the comment @pieper. I received this data this way from my collaborating physician. I will check back with them.

But do you think this is causing the segmentation issues I described in my original post?

Update:

I have 3 other datasets and I am having the same issue described in the original post. I could really use some help :slight_smile: Thank you.

Hi,

This looks like a big “leak” from the airway segmentation. From your screenshot, it appears that your threshold sliders are all out of range.

  • set your upper lung threshold to -400 (should be almost always ok)
  • set your upper airway threshold to -800 (play with that between -900 and -700, see toolext help when you move your mouse over the slider)

image

If you have a large trachea, set airway segmentation → “low detail”
With a normal trachea, set → medium detail" or even “high detail”.

We are working to get those fine-tuning parameters better preset, but once you find good thresholds for your scanner you should be ok.

I think yes, the segmentation relies on the orientation being standard; maybe not but I think so. You can use the Transforms module to rotate (or maybe flip) the data and then harden it before running the algorithm. Together with the updates to the thresholds you should be okay.

Thanks for the feedback @rbumm. I tried the complete range you suggested, but unfortunately, that did not work. I can see the airways are being segmented. However, they are still combined with the Pleura.

I tried the segmentation editor option (as explained in this video). It works but the segmentation quality is not so good. I can see the airways are being segmented nicely, but as you said there is a leak. But not sure how to find this out :confused:.

I haven’t tried the suggestion given by Steve yet.

Sorry but I think I read a name on the dataset you provided above …
Maybe you better delete that post?

Then do the following:
Download Slicer´s lung demo dataset

image

and run the latest version of Lung CT Segmenter on this.
Use these settings:

image

Will work :wink:
Then identify the difference between your patient volume and the demo dataset.
Good luck !

1 Like

Thanks @rbumm. Apologies for the delay in my reply. I can confirm that the sample dataset works. However, on the data I collected, it still has this issue.

I tried using the seed-based segmentation shown in this example(Airway segmentation from CT in 1 minute using 3D Slicer - YouTube). It works without segmenting the lung as part of the airway; however I am not happy with the details in the segmentation.

Any suggestions on how to proceed? Do you have any suggestions on alternate tools that I can try to segment my data?

Thanks!

Could you share one of your non-working data sets on google drive or dropbox?