How to group fiducial markups?


I am having issues grouping the individual folders of fiducial markups into a single folder so I can edit them at the parent level to reflect the changes made to all of it. From the picture attached, t how do I group the already created markups highlighted in a blue box into a parent folder? I tried going to Data module and right clicking on the empty space in the subject hierarchy to create hierarchy from the loaded directory structure and also tried creating a new folder and dropping these markups into them. But I cannot see any changes made to these markups when I edit the parent folder. Any guidance on this is appreciated.

We’ve been testing an add-on to the SlicerMorph extension that will do this. I will push this tonight, so it should be available in the SlicerMorph extension in the next preview build.

Does that mean that it is not possible to do this under the subject hierarchy?

Visibility, opacity, and color can be set at the folder level as described in the post here.

The SlicerMorph implementation copies most display properties (glyph, label, etc), and lock flags, from one node in a folder to each sibling. There is also an option to assign a unique color to each node.

I tried creating a new folder and added the markup-fiducial that I wanted to edit or turn off the visibility at once by dragging each file individually and also by choosing all at once and dropping them in the new folder. I did this under the data module. See the attached images. I do not get all the markups under the folder when I view them under the markups module.

Also when I create a folder in the Markups module, it does not allow me to drag and drop the files into the folder. If I manage to individually drag and drop them into the new folder, when I turn off the eye icon it escapes back out of the folder.

After trying to create folders and failing,I am having issues to load the new set of .mrb folders to try on another subject so I have to close the entire software and re-open again to load the next subject.

I’m not seeing this issue with the folders, which version of Slicer and OS are you using?

Im using Slicer 4.11.20210226
and Mac OS

I’m seeing the same behavior using the Stable version (4.11.20210226). The current Preview version doesn’t have these issues, so it’s probably due to a bug fix since the last stable was released. I’d recommend you download the Preview version and use that instead.

Still does not work for the entire set of markups I just dragged and dropped. Only part of the markups in the folder change the properties as edited at the folder level.

Also the module panel cannot be resized to expand or reduce vertically, which makes it very hard to drag and drop the markups into the folder

When I turned off the visibility at the folder level, slicer shut down unexpectedly.

The view should autoscroll if you are near the edges. That said, if you want to move many points then it may be faster to write a few-line Python script to do what you need.

Please provide instructions how to reproduce the issue and we’ll fix it immediately. Slicer crashes are extremely rare and we take them very seriously.

Preview version crashes all the time.

It would be much more helpful if you could describe exactly which steps you take that lead to crashes. As @lassoan said, we take crashes very seriously and ask for your help in fixing them.

I can also try to replicate the issue on my Mac with with your data if you have a sample you can share, along with the steps that lead to the crash.

I’m still not seeing a crash, but I did find an error in the data hierarchy that appears to be Mac specific, since it’s working fine on my Windows OS. The steps to replicate on a Mac are:

  1. Create a folder in the Data module
  2. Create a few fiducial nodes (I used 3)
  3. From the Data module, drag and drop the nodes in to the first folder. Adjusting the color/properties at the folder level did not work for me at this step.
  4. Switch to the Markups module. In the module, the nodes do not appear in the folder.

If the nodes had been dragged and dropped from the Markups module, everything works as expected, so that event is probably being missed by the Data module.

I cannot reproduce the error that you described. Can you reproduce it using an official Slicer build? Can you record a screen capture video?

I’m attaching a screen capture from the Mac preview version from the downloads page today, 4.13.0-2021-09-29 r30275.

After adjusting the folder properties, the folder is not visible in the Markups module. When switching back to the Data module, one of the markup nodes is not visible.

I’m also having this issue with an older Preview version on my computer, 4.13.0-2021-09-13 r30181. In the stable version I’m not able to add nodes to a folder.

1 Like


Sorry for the delay. When I used the preview version, I loaded the scans which are saved in .mrb format, there are fiducial marker folders existing like the image I posted. I created a new folder and tried putting the first 3 fiducial folders, when I went beyond that the software just shut down and I got an error message. When I asked another colleague, they mentioned that this version usually crashes unexpectedly.

If you or your colleague know of specific actions that that lead to crashes please report the details so they can be fixed.

We do not use the preview version anymore. I dont think it was one particular action, but from my end, it was during the above mentioned steps when the software shut down.