How to import all dicom files into one volume

dicom

(TingtingYu) #1

Hi,

I have a binary file contains volumetric information and its format was converted into DICOM format. Each .dcm file contains one-slide information. Then I imported all these dicom files, however, each slide was shown as a volume. Could you please show me how to import these DICOM files and form only one 3D volume? Thanks in advanced.

Best wishes,
Tingting

image


(Steve Pieper) #2

Creating valid dicom data can be tricky - you may be better off trying to load the original volume data. If you can share the data or provide more information about it we might be able to help.


(Andras Lasso) #3

It seems that you have selected multiple files. When you load DICOM data, drag-and-drop the containing folder to the Slicer application screen and not individual files. See DICOM module documentation for detailed instructions.


(TingtingYu) #4

Hi Steve,

Thank you for your quick reply. Below is the link that shares binary file. The grid size is 256x256x152.

https://drive.google.com/file/d/1kiWJX9rBdzH00v_Sa27b10HOOVTgWHjG/view?usp=sharing

Best,
Tingting


(TingtingYu) #5

Hi Andras,

Thank you for your response. I dragged and dropped the folder to the Slicer application screen. But it still show the same problem.

Best,
Tingting


(Steve Pieper) #6

Hi @TingtingYu -

It does appear that the dicom files haven’t been converted properly. To load as a volume they would need to all be in the same study and series.

I would have a look, but the .bin file you posted won’t open for me. Can you post a .zip instead?

-Steve


(Andras Lasso) #7

You might be able to fix these invalid files using DICOM Patcher module, by enabling “Force same patient name and ID in each directory” option.


(TingtingYu) #8

Hi Steve,

Thank you for your help. No problem. Below is the .zip file.

https://drive.google.com/file/d/1wmWkbIqVuBBTiXpX6z3pNVmWYJAJ863E/view?usp=sharing

Best,
Tingting


(TingtingYu) #9

Hi Andras,

Thank you for helping me.
I tried the DICOM Patcher Module, but it still did not work. It gave me the warning below.

Best,
Tingting


(Andras Lasso) #10

The yip file contains a single “xcat-TrunPhanLesn-atn.bin” file in a file format that I don’t recognize. Please zip the folder that contains the DICOM files and send that.


(TingtingYu) #11

Hi Andras,

Below is the link that shares zipped folder containing DICOM files.

https://drive.google.com/file/d/1PCokDgtJUViGLLEw5Z4QCIURvia0qP0R/view?usp=sharing

I also share how I converted the format, it might help you read the .bin file.

image

Best,
Tingting


Import DICOM files problem
(Andras Lasso) #12

You cannot create valid DICOM files like this. There are a number of required DICOM fields that you must set correctly (patient name, patient ID, series instance UID, image position patient, image orientation patient, etc). If you don’t want to learn how to create valid DICOM files then you can use using nrrdwrite.m to save the voxel array as .nrrd file that you can directly load into Slicer.


(TingtingYu) #13

Hi Andras,

Thank you very much! It works.

Best wishes,
Tingting

image