How to install pedicle screws simulator extension?

Operating system:mac
Slicer version:4.7
Expected behavior: a new downloaded extension for pedicle screws simulator ,I saw the video about that on youtube, and expected it work in 3d slicer.
Actual behavior:i found the extension in GitHub,and download the zip file directly.but it can’t be loaded into 3d slicer as an extension,the tip is as the follow:No extension description found in archive ‘/Users/gujiyong/Desktop/PedicleScrewSimulator-master.zip’.what is wrong with that and what should I do ?appreciate for your help! thank you!

I’ve invited Stewart McLachlin, the author of the pedicle screw simulator module, to answer this question here. I hope we’ll hear from him soon.

It’s very kind of you to reply so soon,thank you professor lassoan.
and the video link is : https://youtu.be/XN3Tp8jaYdQ
It is amazing,isn’t it?

Thanks for your interest in this project. We are currently working towards getting this project ready for the Extension Manager and should have something available for you to use soon. There have been many improvements since the video of the Slicer 4.2 version was posted on youtube in 2014. This is the main reason why the module no longer works since there have been a number of big changes (vtk, markups, etc.) since 4.2 was released.

2 Likes

oh, that is it. thanks for your reply,professor smclashlin,and I am looking forward your new project because that is very very amazing and wonderful!

I’ve fixed trivial issues in my fork and converted the module to a full extension that works with latest version of Slicer.

If you merge [this pull request] (https://github.com/smclach/PedicleScrewSimulator/pull/4) and update the icon and description of the extension then I can submit it to the extension manager.

1 Like

thank you for your help. however I download your fixed extension,but the problem is not solved.maybe my work step is not right, can you help me with that? I downloaded your zip file in GitHub,and open 3d slicer—extension manager–install extension from file–the downloaded zip file, but the same problem appeared:No extension description found in archive ‘/Users/gujiyong/Desktop/PedicleScrewSimulator-master.zip.shall I downloaded other extension first?thank you!

Extension package is not generated yet - it needs merging of pull request and improving icon and documentation. It is not a lot of work, so I hope it’ll be done soon.

In the meantime, if you want a preview of how the extension will work then you can download all the files (clone the repository; or download as a zip and unzip to a local folder) and in Application settings / Modules add the directory that contains PedicleScrewSimulator.py to Additional module paths.

1 Like

got it, i will try to do it.thank you.best wish to you,i hope the extension will be done and used soon.

hello professor smclachlin, i saw the files about this extension have been updated in GitHub,does it mean that I can use it in 3d-slicer? thank you

It’ll be improved but you can use it already. For now you have to download and add the extension to the module paths as described above.

yeah,it works! it is incredible to me! thank you both!
however, what should I do if I need some other screws with different scales? for example screws with length 30mm.35mm.40mm.45mm,and width 50mm,55mm,60mm,65mm,70mm,75mm.
further more,i appreciate if add some size of screws for cervical vertebra.thank you very much!

You have the full source code of the module. Feel free to edit it and add the models you need. If you make any improvements to the module, please consider contributing back those by sending pull requests.

ok, i see,thank you again.:grin::grinning:

It is very good for us.

Thanks,everyone.PedicleScrewSimulator

Could someone tell me what this module is not working properly in my PC? When I try to load screw it is giving me the error message attached below. I can’t load screw. What Shoul I do?

image

1 Like

I’ve fixed the issue, see the updated extension here: https://github.com/lassoan/PedicleScrewSimulator

I’ve also submitted it to the extension manager, so it may be available in the extension manager from tomorrow.

1 Like

Thank you very much.

I am still getting error to load sample CT. Inaddition, it is loading screw in opposite direction (from anterior to the direction of posterior). Please find attached picture for your consideration.

image

image

It could be the download was incomplete or corrupted - try deleting the file (path is in the python output) and trying again.

1 Like

I know you just said this two days ago, but I’m eager to install this and I can’t find it in the extension manager yet. I also tried downloading it from the git, then going to application settings->modules->add module path to do it that way but Slicer just won’t seem to recognize that there is anything there. Any idea what I might be doing wrong?

Running slicer 4.9.0