How to load TIFF image stacks that don't have scalar overlay already associated?

I have a few TIFF image stacks that when I load into Slicer seem to only have a volume data set and no scalar overlay data associated with them and therefore load in an illogical way. When I load different TIFF image stacks that seem to “come with” a scalar overlay meaning that it appears in data loading box, they load fine. All these data sets (with and without scalar overlay data) load fine in Dragonfly, leading me to suspect there is a way to load image stacks that don’t have scalar overlay data in Dragonfly but I don’t know how. I would prefer to use Slicer for all these data sets if possible.

I am not sure what you mean by ‘load in an illogical way’. You do not need a scalar overlay for an image stack to be imported as scalar volume.

Just drag and drop one of the tiff files, uncheck the option ‘single file’ and then you should be able to read your image stack as a scalar volume (not overlay). If this is a RBG stack, then you may have to use the vector2scalar module to convert them as a scalar.

If you can tell us more about these stacks, better yet share one we can probably help more. I do not know anything about Dragonfly.

Thanks of getting back to me. Dragging and dropping didn’t work and I tried the vector to scalar module but I must be doing something wrong because I cant get the Input Vector Volume drop down to work. Whats the best way to share a data set with you?

Yes, it will hep to look at an example. You can use dropbox, google drive, or microsoft onedrive, whatever is easiest for you to share.

here is a link to a folder with one of the TIFF image stacks that I having trouble loading.

Thanks, downloading right now. Next time packaging them into single zip file would be preferable.

Once I downloaded it seems to load up just fine. I selected one file, turned on the load options and unchecked “Single file”. Then in the Volumes module I set the slice spacing to 0.015 to match the in plane spacing. The image quality looks great.

1 Like

Yep, works just fine. Here is a visual of load data dialog box. I just replaced the filename (which was too long, with hagfish), and unchecked the Single File option.

1 Like

Still struggling. Here’s what I did. selected Load Data > Choose File(s) to Add and selected one TIFF from the stack as shown below.

Then unchecked single file and changed volume name to hagfish as shown below.

Loads like this…

Sorry that second screen capture should have looked like this…

Go to volumes module and check your data

  1. Does volume dimensions make sense?
  2. Is the slice spacing across three axes correct?

If the image stack loaded correctly, I suspect you are suffering from #2.

OK, finally got it. Thanks for your patience!

Tiff is not a suitable format to retain image geometry. Make sure to save your volume as nrrd file so that you don’t encounter the same issue when you reload your data.