How to scale dimensions of the segmentations to match new volume image spacing

So I have run into an issue here.
I started segmenting a z-stack of images and forgot to specify the volume image spacing dimensions beforehand.

After changing the volume to the correct images the segmentations no longer match.
Is there a way to scale the label maps to match the new dimensions properly?

Best,
a humble grad student

To change the segmentation to match a selected volume’s geometry, you can use Specify geometry. You may apply some smoothing after this resampling (e.g., joint smoothing).

Thank you for providing this link! I have a similar situation - I need to change the volumes of the segmentation. However, the specify geometry button won’t let me change each dimension separately (x, y need to be the same size but z is larger). Do you know of a way to do this? Thank you!

I would recommend to use isotropic spacing - same resolution along all axes because that allows you to use all details of the segmentation for creating a smooth 3D model.

If for some reason you must exactly match the spacing of another volume then you can uncheck the “isotropic spacing” option in the “Segmentation geometry” window.

Trying to solve a similar situation… I made a segmentation on a volume with incorrect spacing information, and would like to update the spacing of the volume and segmentation to the correct values. I first changed the spacing on the volume from the “volumes” tab, then went to “specify geometry” to try to change the spacing on the segmentation, but all spacing fields are greyed out.
I tried selecting the volume as source geometry in “specify geometry” then just pressing “ok” - this seems to have changed the segment’s labelmap geometry (the display changed, and the segment labelmap now shows the same spacing info as the volume) but the resulting segment does not correctly align with the volume. What step could I be missing?
The initial (incorrect) spacing was 0.0015 x 0.0015 x 1, and the spacing I’m trying to change to is 0.5 x 0.5 x 1… not sure if the large scaling jump may be causing part of my issues.

You can export the segmentation to labelmap volume, use Volume information section in Volumes module’s to change spacing, and then convert the labelmap to segmentation.

If you find that this removes some metadata that you want to preserve (segment terminology, layers, etc.) then an easy way is to save the segmentation into seg.nhdr file. In this file format the header and the voxel data are saved in separate files. You can use notepad or any other text editor application to modify the spacing values in the .nhdr file.