Rescaling Segmentations

Hello Slicer Community,

I recently began using 3D Slicer as an alternative to Mimics, so I am still learning the nuances of the program, but I’ve run into a bit of a problem while conducting segmentations. During my first segmentation, I inadvertently scaled up the image spacing to 0.732558 mm * 0.732558 mm * 1 mm (the original image spacing for the TIFF stack that I was working with was 0.063 mm * 0.063 mm * 0.086 mm, but I scaled up the spacing because, at the time, I didn’t know how to refocus on a smaller field of view in each panel). I thought that I could rescale the model when I went to export the segmentations as STL files, but the scale factors I have tried have been producing models that are much too small and/or much to larger relative to other models that I have produced for different structures using the appropriate image spacing.

Is there a way to rescale the segmentations to fit the original image spacing, or, alternatively, is there a better way to calculate the scale factor during model export to get the appropriate model size? If anyone has any suggestions, I would very much like to hear them!

You can click Specify geometry button in Segment Editor module to adjust the spacing of the segmentation. After that you probably want to smooth the segmentation to take advantage of the increased resolution.

When I open the Specify geometry panel for the master volume, all of the numeric entry fields are grayed out (i.e., I can’t edit them). Is there any reason why that might be the case, and is there any way to fix it?

Yes, you need to select a source node as described here.

When I select either the master volume or the segmentation as the source geometry in the Specify geometry panel, the numeric entry fields remained grayed out. I reviewed the page that you linked, but it doesn’t seem to specify any additional information about why this might be happening. Is there something that I am missing?

Can you post a screenshot?

It should be possible to enter spacing, everything else is computed from that.

1 Like

Alright, here is a screenshot of the panel.

This looks good! You can specify spacing by specifying oversampling factor and isotropic spacing checkbox and see the resulting geometry in the “Segmentation labelmap geometry” section.

Thank you! When I tried applying the oversampling factor, though, I received the following error:

“Bad allocation” means that you have run out of memory. Since oversampling by a factor of 2 increases memory need by almost a magnitude, it is easy to go overboard. I would recommend to upgrade to latest Slicer Preview Release, as we have made memory management of non-overlapping segments more efficient. You can also increase virtual memory size in your system settings to make sure that there is always enough memory space (I would recommend having 10x more memory than your raw data size to allow enough memory for data processing and visualization).