I can't build Slicer master branch in Windows10 via VisualStudio2019(toolset v142),Qt5.15.2

@jamesobutler @lassoan
I tried to build a different release in a different environment, but I failed every time, so I’m trying to build the current branch.
I just tried to build Slicer master branch in Windows 10 via VisualStudio2019 (toolset v142),Qt5.15.2 ,CMake 3.21.3 but I failed.
I cleaned the build tree every time I tried. but I can’t find Slicer.exe in C:\D\S4R\Slicer_build.
Every time I try LibArchive.vcxproj, SimpleITK.vcxproj, and Slicer.vcxproj fail to build.

And I tried to build it at CMD, but it failed, and there were more errors at this time.
I also ran the development setup via Git-Bash-Here listed in the build-instruction when using or not using the CMake-GUI.
Do I have to install ITK, VTK, Python before build and then use it to build?

Lastly, I want to do AR programming using IGT, PlusToolKit, and Slicer, so I want to succeed in building and run Slicer.exe.
Please advice and help me…


this is message when I configure in CMake-GUI .
You can configuration Full log.txt in here and after Generate Log in here

The messages in the last picture are just warnings. You can safely ignore them.

The build error and solution (workaround) is discussed here.