Incomplete options in SlicerCIP (SlicerCIP4-10-2) on Windows (Windows 7 Enterprise, Service Pack 1) and Linux (Ubuntu 18.04.4 LTS)

Hello Dear Developers and Users

As mentioned on the sixth page of this file in Interactive Lobe segmentation, when filtering is ”on” I expect to open a new frame opens for selecting filter type (NLM, Median and Gaussian), but it is not occurred for me.

I installed last version of SlicerCIP (SlicerCIP4-10-2) on Windows (Windows 7 Enterprise, Service Pack 1) and Linux (Ubuntu 18.04.4 LTS) and I do not this option (selecting filter). Why?

Please guide me.

Thanks a lot.

Shahrokh

Do you see any error messages in application log (menu: Help / Report a bug)?

When I run it in Ubuntu:

sn@MP:~$ cd /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2

sn@MP:~/SlicerCIP4-10-2-linux/SlicerCIP4-10-2$ ./SlicerCIP4-10-2

I get the following log message:

[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Session start time …: 2020-08-19 09:22:33
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Slicer version …: 4.10.2 (revision 28257) linux-amd64 - installed release
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Operating system …: Linux / 5.4.0-42-generic / #46~18.04.1-Ubuntu SMP Fri Jul 10 07:21:24 UTC 2020 - 64-bit
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Memory …: 15864 MB physical, 2047 MB virtual
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - CPU …: GenuineIntel Intel® Core™ i7-9700K CPU @ 3.60GHz, 8 cores, 8 logical processors
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - VTK configuration …: OpenGL2 rendering, Sequential threading
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Developer mode enabled …: no
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Prefer executable CLI …: yes
[DEBUG][Qt] 19.08.2020 09:22:33 [] (unknown:0) - Additional module paths …: /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/bin/…/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/cli-modules, /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/bin/…/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/qt-loadable-modules, /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/bin/…/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/qt-scripted-modules
[CRITICAL][Qt] 19.08.2020 09:22:34 [] (unknown:0) - Error(s):
Cannot load library /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/qt-loadable-modules/libqSlicerAirwayInspectorModule.so: (libvtkSlicerAirwayInspectorModuleLogic.so: cannot open shared object file: No such file or directory)
[CRITICAL][Qt] 19.08.2020 09:22:34 [] (unknown:0) - Error(s):
Cannot load library /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/qt-loadable-modules/libqSlicerParticlesDisplayModule.so: (libvtkSlicerParticlesDisplayModuleLogic.so: cannot open shared object file: No such file or directory)
[CRITICAL][Qt] 19.08.2020 09:22:34 [] (unknown:0) - Error(s):
Cannot load library /home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/SlicerCIP4-10-2-Extensions/Chest_Imaging_Platform/lib/Slicer-4.10/qt-loadable-modules/libqSlicerRegionTypeModule.so: (libvtkSlicerRegionTypeModuleLogic.so: cannot open shared object file: No such file or directory)
[ERROR][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py:16) - Failed to import ._init: Traceback (most recent call last):
File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
exec(importStr)
File “”, line 1, in
ImportError: No module named _init
[ERROR][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py:16) - Failed to import ._AbstractScriptedSubjectHierarchyPlugin: Traceback (most recent call last):
File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
exec(importStr)
File “”, line 1, in
ImportError: No module named _AbstractScriptedSubjectHierarchyPlugin
[ERROR][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py:16) - Failed to import ._AnnotationsSubjectHierarchyPlugin: Traceback (most recent call last):
File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
exec(importStr)
File “”, line 1, in
ImportError: No module named _AnnotationsSubjectHierarchyPlugin
[ERROR][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py:16) - Failed to import ._SegmentEditorSubjectHierarchyPlugin: Traceback (most recent call last):
File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
exec(importStr)
File “”, line 1, in
ImportError: No module named _SegmentEditorSubjectHierarchyPlugin
[ERROR][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py:16) - Failed to import ._SegmentStatisticsSubjectHierarchyPlugin: Traceback (most recent call last):
File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
exec(importStr)
File “”, line 1, in
ImportError: No module named _SegmentStatisticsSubjectHierarchyPlugin
[DEBUG][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - Failed to import ._init: Traceback (most recent call last):
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - exec(importStr)
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “”, line 1, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - ImportError: No module named _init
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) -
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - Failed to import ._AbstractScriptedSubjectHierarchyPlugin: Traceback (most recent call last):
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - exec(importStr)
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “”, line 1, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - ImportError: No module named _AbstractScriptedSubjectHierarchyPlugin
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) -
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - Failed to import ._AnnotationsSubjectHierarchyPlugin: Traceback (most recent call last):
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - exec(importStr)
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “”, line 1, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - ImportError: No module named _AnnotationsSubjectHierarchyPlugin
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) -
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - Failed to import ._SegmentEditorSubjectHierarchyPlugin: Traceback (most recent call last):
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - exec(importStr)
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “”, line 1, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - ImportError: No module named _SegmentEditorSubjectHierarchyPlugin
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) -
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - Failed to import ._SegmentStatisticsSubjectHierarchyPlugin: Traceback (most recent call last):
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/init.py”, line 14, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - exec(importStr)
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - File “”, line 1, in
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) - ImportError: No module named _SegmentStatisticsSubjectHierarchyPlugin
[CRITICAL][Stream] 19.08.2020 09:22:36 [] (unknown:0) -
[DEBUG][Python] 19.08.2020 09:22:36 [Python] (/home/sn/SlicerCIP4-10-2-linux/SlicerCIP4-10-2/lib/Slicer-4.10/qt-scripted-modules/SubjectHierarchyPlugins/AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Qt] 19.08.2020 09:22:37 [] (unknown:0) - Switch to module: “Welcome”

In Windows:

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Session start time …: ???-??-?? ??:??:??

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Slicer version …: 4.11.0-2020-07-18 (revision 29221 / 26fbefd) win-amd64 - installed release

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Operating system …: Windows / 7 / (Build 7601, Code Page 1256) - 64-bit

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Memory …: 8076 MB physical, 16150 MB virtual

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - CPU …: GenuineIntel , 8 cores, 8 logical processors

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - VTK configuration …: OpenGL2 rendering, TBB threading

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Qt configuration …: version 5.15.0, with SSL, requested OpenGL 3.2 (compatibility profile)

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Developer mode enabled …: no

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Prefer executable CLI …: yes

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Application path …: C:/Users/naserish/AppData/Local/NA-MIC/Slicer 4.11.0-2020-07-18/bin

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Additional module paths …: C:/Users/naserish/AppData/Roaming/NA-MIC/Extensions-29221/Chest_Imaging_Platform/lib/Slicer-4.11/cli-modules, C:/Users/naserish/AppData/Roaming/NA-MIC/Extensions-29221/Chest_Imaging_Platform/lib/Slicer-4.11/qt-loadable-modules, C:/Users/naserish/AppData/Roaming/NA-MIC/Extensions-29221/Chest_Imaging_Platform/lib/Slicer-4.11/qt-scripted-modules

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - Traceback (most recent call last):

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “”, line 1, in

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “C:\Users\naserish\AppData\Local\NA-MIC\Slicer 4.11.0-2020-07-18\lib\Python\Lib\imp.py”, line 170, in load_source

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - module = _exec(spec, sys.modules[name])

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “”, line 618, in _exec

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “”, line 678, in exec_module

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “”, line 219, in _call_with_frames_removed

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - File “C:/Users/naserish/AppData/Roaming/NA-MIC/Extensions-29221/Chest_Imaging_Platform/lib/Slicer-4.11/qt-scripted-modules/CIP_BodyComposition.py”, line 18, in

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - from .CIP_BodyComposition_logic import BodyCompositionParameters

[CRITICAL][Stream] ??.??.??? ??:??:?? [] (unknown:0) - ImportError: attempted relative import with no known parent package

[CRITICAL][Qt] ??.??.??? ??:??:?? [] (unknown:0) - loadSourceAsModule - Failed to load file “C:/Users/naserish/AppData/Roaming/NA-MIC/Extensions-29221/Chest_Imaging_Platform/lib/Slicer-4.11/qt-scripted-modules/CIP_BodyComposition.py” as module “CIP_BodyComposition” !

[CRITICAL][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Fail to instantiate module “CIP_BodyComposition”

[CRITICAL][Qt] ??.??.??? ??:??:?? [] (unknown:0) - The following modules failed to be instantiated:

[CRITICAL][Qt] ??.??.??? ??:??:?? [] (unknown:0) - CIP_BodyComposition

[DEBUG][Python] ??.??.??? ??:??:?? [Python] (C:\Users\naserish\AppData\Local\NA-MIC\Slicer 4.11.0-2020-07-18\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations

[WARNING][Qt] ??.??.??? ??:??:?? [] (unknown:0) - When loading module “ParticlesDisplay” , the dependency “TractographyDisplay” failed to be loaded.

[DEBUG][Python] ??.??.??? ??:??:?? [Python] (C:\Users\naserish\AppData\Local\NA-MIC\Slicer 4.11.0-2020-07-18\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor

[DEBUG][Python] ??.??.??? ??:??:?? [Python] (C:\Users\naserish\AppData\Local\NA-MIC\Slicer 4.11.0-2020-07-18\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics

[DEBUG][Qt] ??.??.??? ??:??:?? [] (unknown:0) - Switch to module: “Welcome”

Best regards.

I’ve tried the latest Slicer Preview Release on Windows and it worked well.

Thanks a lot

Anyway, I still get these errors. I found a solution to this problem. I find filters available when filtering is ON (NLM, Median and Gaussian) in Processing category of Chest Imaging Platform which include: GenerateNLMFilteredImage and GenerateMedianFilteredImage.

1 Like