Why my computer bug when I start parenchyma analysis after segmentation?

Operating system: MacBookPro11,1 ; intel Core i5; 2,6GHz; RAM 8Go
Slicer version: SlicerCIP 4.10.2

Why my computer bug when I start parenchyma analysis after segmentation?
I can segment lungs and lobes but the software bug when I perform parenchyma analysis to obtain lung densitometry…
Is my computer not powerful enough


Hi -

Can you post the error log and more details as described here:



Hi Steve,
Thank you for your rapid answer.
I’m not a developer so I can’t do anything manually…
I notice first that when I click on Filtering “On” nothing appears.
Second When I apply for parenchyma analysis from my CT images (precising Label Map Volume = None) segmentation appears but no “Histogram” and no “Chart section”.
Then when I apply with Label Map Volume = myCTpartialLungLabelMap (segmentation) it starts analysing and then shut down…
I can’t say anymore.
See screenshot attached if it’s working

Nothing happens when you click “Filtering on” because there is AttributeError: QFrame has no attribute named 'setShown'. This is a problem with the code here. setShown is specifically a Qt3 thing that was supported in Qt4 to help with that transition of 3 to 4. That transition happened a long time ago, so not sure how much effort is being put into SlicerCIP recently. Unclear if SlicerCIP will be updated for Slicer5/Slicer-preview which includes the transition to Qt5.

@jcfr and @cpinter have issued some commits to SlicerCIP in the past, but I’m not sure who the best person to contact would be to fix various issues in the code. You say you’re not a developer, but you could potentially create a GitHub account and post an issue to https://github.com/acil-bwh/SlicerCIP/issues detailing the problems that you are seeing.

Look like this particular issue has been addressed in https://github.com/acil-bwh/SlicerCIP/commit/115959155cdb5f6bfbeffc6c1f794fcb6bdeb509

Thanks @PNardelli :pray:

Since the extensionIndex is already associated with the develop branch where the fix has been integrated, tomorrow extensions should include the fix :tada:


@Benjamin_Coiffard are you able to confirm the fix that @PNardelli provide?

Hi Steve,
You know those scripts are just Chinese for me.
I tried to put this one in the Python Interactor put it doesn’t work from that point…

haha :wink:

But if you download a new nightly build of Slicer you should be able to install the latest CIP extension.

Thanks Steve
But I tried already but I don’t even know how to install the latest CIP extension on 3D Slicer version 11. There is now CIP in the Extensions Manager.
I’m going crazy… I really need to use CIP…

It looks like there are still some problems with the build and that’s why the extension is not showing up.

@PNardelli do you know how to fix these?