Integration of 3d slicer in Google Cloud Shell

Hi everyone,
Hope everyone is doing well.
I would like to know how we can run 3dslicer using docker in google platform (GCS).
I have tried running docker command to run 3d slicer on google cloud shell, using command

docker run -p 8888:8888 -p49053:49053 -v “$PWD”:/home/sliceruser/work --rm -ti lassoan/slicer-notebook:latest
and I am able to open notebook in browser with provided link.
However, when I tried to create a new notebook for slicer or python by clicking on “New” and selecting “Slicer5.0”, it prompts me error saying “Cannot create a new notebook” as shown below.

Please do let me know, if anyone has successfully run 3d slicer in google cloud.

You can run a slicer desktop environment with these instructions, but you can also run a full Jupyter/Slicer stack using the instructions Google provides for their Medical Imaging Suite.

Hi ,
I tried with first option , which gives me error message as shown.
Is there any steps I need to take before executing this command?
And with second option of google medical imaging suite , I have tried creating jupyter notebook instance. When I launch the jupyter notebook, there is no option of slicer under new menu, from where I can launch 3d slicer.
Please advise me on this.

it looks like you changed the --image-project option to be your project, but this didn’t need to be changed since the slicer images are in the idc-sandbox-000 project. Your account’s currently configured billing project is used be default so you don’t need to put it on the command line. Note there are some draft instructions for creating a VM without a GPU if that fits your use case (it’s much cheaper).

I’m not sure about the Google suite, but probably you can find support from them. It’s brand new so I guess they’ll want feedback.

Thank you for the reply.
Following the draft instruction of creating vm without gpu addition, the instance is created and running successfully
When running this command,

gcloud compute ssh ${VMNAME} – -L 6080:localhost:6080
it prompts message saying “bind [::1]:6080: Cannot assign requested address” as shown in image.

However it takes me inside vm and inside it I run all commands as shown and when I try to visit link
Its not reachable and desktop is not accessible.

Could you please let me know if I missed something.

Looks like you are close @Binita_Shrestha. When it says it cannot bind the address that usually means there’s another process using the port. For me that happens if I have another ssh session running, maybe from an earlier login attempt or reusing the same port for a different virtual machine. Doing ps -ef | grep 6080 may help you identify the process and kill it, or if you aren’t familiar with that you could just reboot your local machine to clean out the old process.

Or you can use a different localhost port. That is, try using 6081:localhost:6080 in the ssh command and then connect to http://localhost:6081/vnc.html?autoconnect=true in your local client browser.

Thanks Steve,
Actually I tried changing the port and checked for the process used by the port 6080, but that didn’t get rid of this error.
However I will try again with boot and see how it goes and let you know.