Is XCode required to use Slicer on mac?

I was helping a clinical researcher to set up 4.10 on mac, and I ran into the message below. Installing XCode is a long step that I would not expect to be required to use Slicer. I don’t think XCode was required in the past.

Apparently, we were able to proceed with “Not Now”, but it is not clear what (if any) functionality of Slicer would not be available due to this.

There is no mention of XCode requirements in the install instructions here: https://www.slicer.org/wiki/New_users#Installing_3D_Slicer

image

Out of fear this will be lost in the weeds, issue submitted: https://issues.slicer.org/view.php?id=4654

Fixed, it will not ask for git in nightly builds downloaded tomorrow and later.

2 Likes