Keystrokes from Editor to Segment Editor

Would it be possible to transfer all Keystrokes from the Editor:
https://www.slicer.org/wiki/Documentation/Nightly/Modules/Editor
to the SegmentEditor
https://www.slicer.org/wiki/Documentation/Nightly/Modules/SegmentEditor
?

Thanks in advance

The Segment editor has more shortcuts and they are optimized for blind one-handed use. See complete list here: http://slicer.readthedocs.io/en/latest/user_guide/module_segmenteditor.html

1 Like

Thanks for the hint :wink:

I’ll try out and give some feedback.

Works great. Thank you.

I think there is only a bug that the view is reset to the default view if you use the Segment Editor for the first time or switch between different Segmentations?

Actually, I think it is a feature, not a bug. Can you describe what you did, what you wanted to happen, and what happened instead?

For example:

  • I use Segment Editor and segement the hip joint in the coronal plane (View: “Green slice only”)
  • I use the shift key to move the other planes Red and Yellow to the same position.
  • Now I change view to “Red slice only”.
  • IMO the Red slice should be somewhere in the hip joint now, but it is in the default position.

This works in the “Four-Up” view. But it doesn’t work if I switch between "Green / Red / Yellow slice only"
The slice position is always reset to default, if I change between different Views.

Kind regards

When you switch between layouts the slice position should not change. This seems to be a bug - I’ll look into this.

I’ve fixed the problem, it’ll work correctly in the nightly version that you download tomorrow or later.

1 Like

Thank you! Works fine.

By the way. I forgot to mention that the “Subject Hierarchy” Button is not working for me.

And may it be possible to store the last settings of the Segment Editor in the mrml file somehow?
For example the last segmentation, master volume, segment, view, zoom, pan, …

Kind regards

Subject Hierarchy” Button is not working for me

Subject Hierarchy module has been merged with Data module. In menu: Edit / Application settings, Modules section, Favorite Modules list (at the bottom) you need to:

  1. Remove the old Subject Hierarchy shortcut (click on the shortcut then click Remove)
  2. Create new shortcut: drag-and-drop the Data module from the list above into the Favorite Modules (you can adjust order of shortcuts with left/right arrow buttons)

And may it be possible to store the last settings of the Segment Editor in the mrml file somehow?
For example the last segmentation, master volume, segment, view, zoom, pan, …

All these settings are already stored in the scene file and restored when you load the scene.

In menu: Edit / Application settings, Modules section, Favorite Modules

Thank you, works fine.

All these settings are already stored in the scene file and restored when you load the scene.

This doesn’t work for me. If I open scene file and select the Segment Editor the view is set to default.

There may be some unnecessary reset of views, Ill see if Incan reproduce it. In the meantime, you can try if it works well if you switch to Segment editor, Close scene (even if you haven’t loaded any data yet), and then load your scene.

This seems to work.

Thanks a lot & kind regards

This bug is still present in the latest nightly build. Would be great if this could be fixed.

Maybe another small bug, that I’ve recognized in the Segment Editor:
If “Show 3D” is deactivated through the button, the button of “Show 3D” is still in active mode.

Thanks in advance

I cannot reproduce this. Could you capture a video of your screen, upload it somewhere, and post the link here?

Deactivate using which button?
What do you mean by “still in active mode”?

Here a video after starting slicer:

I’ve changed the segment editor widget to not reset slice view when switching master volume (when switching to Editor module). The new version will be available in the nightly build that you can download on Saturday or later.

Thank you!
Works fine.

1 Like