Load pictures from LayerQam

Hello,

Im working with 3D Printing using Arcam EBM technology. In the EBM machine there is something called LayerQam, a camera that takes pictures on every layer that is melted during the build, with the main purpose to monitor porosity created in the melt pocess, I would like to load these Pictures into 3D slicer to try and make a 3D model to better visualize the porosity found. I have tried to load the Pictures but when loaded I can only make one Picture visible at the time and all the Pictures are on the same z-level. Is there a way to move the Pictures consequenlty one layer thickness for each Picture or is it some other way I can import this type of data? The Pictures are in .png format.

BR Marie Cronskär

See instructions how to load a stack of png images here: https://www.slicer.org/wiki/Documentation/Nightly/FAQ#How_to_load_data_from_a_sequence_of_jpg.2C_tif.2C_or_png_files.3F

Thank you! First time it worked well but when I did the same thing again I can only have one Picture visible at the time (even though I unchecked the “single file” option). Is it some setting I have happened to change or what can the reason be? When I go to “data”, I see all the Pictures in the list but can only have one visible at the time.

Also, it takes a lot of time to change all the “image origin values” of all the Pictures, one at the time, but I guess that is the only way to get the spacing between the Pictures?

BR Marie

It seems that you selected multiple files or a folder. Make sure you only select a single file of your image sequence. If you numbered your files consistently, Slicer will find all the corresponding files.

Ok. Now I have tried to import one picture at the time. I have also tried to give them the names 1, 2, 3… (is that what you mean by numbering the files consistently?) and only selecting the number 1 when importing but then it only imports that picture.

I can still only make one picture visible at the time when imported into slicer.

Skärmklipp

In the “Add data…” dialog, click on “Show Options” and uncheck the “Single File” option.

I did that but it doesnt seem to work.

To make the instructions more clear, I’ve uploaded a video:

Do all the images have exactly the same size?

Could you go to the Volumes module and check what are the values in Volume Information section, Image Dimensions? The third value should be > 1.

1 Like