Loading BRAINSTools modules built standalone into Slicer

Operating system : Mac OS X Version 10.12.6
Slicer version   : 4.6.2
Expected behavior: Have all BRAINSTools extensions installed in the Slicer GUI (especially GTRACT).
Actual behavior  : I downloaded the BRAINSTools from GitHub [1] to './Documents/GitHub/brains/BRAINSTools' 
                   and built it with CMake into a subfolder called 'build'. 

[1] https://github.com/BRAINSia/BRAINSTools.git

How can I now make the extensions appear in Slicer GUI?

Thanks, Lorenz


Few remarks / questions:

Could you confirm that you built BRAINSTools as standalone project ?

Slicer 4.6.2

If you don’t have specific reason to use this version, you could use Slicer 4.8 or even download the nighty build

make the extensions appear in Slicer GUI?

Generally speaking, you could add the directory to the settings or use --additonal-module-paths command line argument. More details here: https://www.slicer.org/wiki/Documentation/Nightly/SlicerApplication/ApplicationSettings#Additional_module_paths

In that particular case, to ensure that the built CLIs load, it is recommended to build BRAINStools statically.

Otherwise, if BRAINSTools is statically built, the executables will try to dynamically resolve symbols against the ITK libraries bundled in Slicer which may be slightly different than the one used to build BRAINSTools.

Hi Jean

Thank you for your prompt response. Regarding your question: Yes, I built BRAINSTools as a standalone project.
However, it’s the first time I have done that and therefore I don’t know how the result of the building process has to look in the end. What kind of files should I expect? Now I have a lot of different subfolders with the names of the different BRAINSTools modules containing files with extensions such as .xml, .cxx, .h, etc. So I’m not even sure the building process was completed correctly. Regardless of that, I downloaded as you suggested the newest nightly build version of Slicer and added my BRAINSTools folder to the paths for modules in Slicer GUI (Edit->Applications Settings->Modules). The BRAINSTools modules still don’t show up upon restart.

Thanks for your help!

Best regards, Lorenz