Oculus controller behavior

Operating system: Windows 10 Family 21H2
Slicer version: 5.2.1

Hello, I’m able to correctly visualize the scene in virtual reality with my oculus quest 2, but my controllers don’t have the expected behavior.
The only thing I get is when I press both grip button to scale the scene, it scales to infinite instantaneously and I lose the objects.
The touchpad doesn’t react so I can’t fly around in the scene, and other functions don’t work either.

I put Json files in slicer folder like below

Here are the settings of VR module

Do you have any idea to solve this problem ?

Thank you

Yes this has been an issue for quite a while (you’d find at least ten topics asking about this), but finally it seems that the basic interactions work. It is super recent and I can only try it tomorrow but you can give it a try now. Please install the latest 5.3 preview version and the SlicerVR for that.

1 Like

Tested it two days ago with no success but is it worth trying again today?

Yes I think so, you might just have tried the last one before the fix. Then again, I haven’t had the chance to try it yet.

I tried it this morning, it doesn’t work. I’ll keep in contact with the people that have funding for it and thus are working on it, and will keep trying every output they have.