One DICOM study loading as multiple


I’m trying to import a CT scan using the DICOM Browser on Slicer 4.10.0. The directory I imported with one study loaded as several studies, each with one series containing one slice.


It’s currently loading one image at a time rather than all the images as a stack. Is there some way I can combine all these studies back into one?

Is this a 4D CT? It seems that the data set has been anonymized and maybe it was done incorrectly.

In 4D CT acquisitions, typically all frames are in the same series and you seem to have many series.

There is a fallback mechanism in the multi-volume DICOM importer in Slicer that can still load the data as a time sequence, but you need to select the whole study (all the series) and certain criteria must be met (number of frames and frame positions are the same for all time points; frames can be grouped based on one of the known frame grouping tags, etc.).

If selecting the study and loading results in loading of many individual frames then check “Advanced” section, click “Examine” to see what options are offered for loading and report back to us.

You can also create a volume sequence from a set of volume nodes in the scene using Sequences module in Sequences extension.

We were trying to anonymize our CTs using Matlab’s dicomanon function but we weren’t sure what fields we needed to keep the DICOM study intact. But all of these should be part of one 3D CT scan. Each slice can be selected in the viewer as a different series. Do you know exactly what tags we’d need to preserve the standard format?

In the advanced tab, there aren’t any options available after clicking “Examine”.

I loaded all the frames into the Sequences module but playback in the Sequences browser isn’t showing anything but the slice position rapidly ticking out of order.

You can get definite answer from DICOM standard Part 3.

Instead of starting from scratch, you can start by inspecting tags present in a CT series created by a clinical scanner. You can find definition of all tags in the standard. You can safely skip all private DICOM tags.