Importing 4D CT DICOM files from Siemens scanner to 3D Slicer

Slicer 5.6.1
Scanner: Siemens SOMATOM Force


I am not able to import a time-resolved cardiac CT sequence, consisting of 10 time points and 300 slices. I tried exporting DICOMs both as separate folders for each time point, and also all the DICOMs in one single folder. I used the examine button and selected different Multivolume options available individually and together (see below). I also tried different combination of “DICOM Plugins” to no avail.

When I scroll through the images in metadata, it goes through all the slices in a time point before advancing to the next time point. Is there a way to sort/read the files in Slicer based on “slice position”?

I appreciate your help in advance.


Your screenshots look OK to me. What happens if you click the “Load” button? In both screenshots, the top, checked option looks like it is a 10 frame volume sequence, which is what you want. You can then go through each frame using the sequence browser.

1 Like

Thanks for the reply.

When I click load, I get the error message on the screen in the 2nd screenshot:

Could not load @@@ 10 frames volume sequence by acquisition time as a Multivolume.

I link to the dataset down here and would really appreciate if you could take a look at your convenience.!An5lW2cr0wILgpskup_vMejEXjWCmw?e=Pb3Xrs


I tried your dataset and it loads OK for me:

Both the first and second options load as Volume Sequences that I can play back. The first is the right one to choose, the second one loads but has step/banding artifacts because it organizes by time instead of by cardiac cycle.

What version of Slicer are you using? I loaded with 5.2.1, which is a little behind the current stable version. If you are using an older version, try upgrading to the current stable and see if that works. The DICOM plugin you need enabled is MultiVolumeImporterPlugin, and then make sure that the one you select is described as a Volume Sequence by CardiacCycle (not a MultiVolume by CardiacCycle; somewhat confusingly, MultiVolume is a deprecated predecessor to Volume Sequences. It is OK that the “Reader” column says MultiVolume, you just don’t want that in the first column). It is possible that the version you are using is getting tripped up by the StudyID, StudyDescription, and SeriesDescription DICOM tags being empty. If you are unable to update your Slicer version, I would try filling in those tags with something and see if that allows you to load.

@mikebind It appears @SassanHashemi is using the latest version of Slicer (5.6.1). If it is working for you with Slicer 5.2.1, maybe you can confirm that it is also working with Slicer 5.6.1.

Apologies I didn’t have access to my laptop for a few days.

This is very strange! I had anonymized the data I shared with you under a different name. I loaded the version I shared with you and to my surprise it loaded fine, exactly the way it loaded for you!

But when I load the data with the other name I was having issues with, it still doesn’t load!

Do you think the name I chose for the dataset had anything to do with it? Just so that I can avoid this issue in the future.

Thanks again for the guidance.


This is very interesting, because anonymization usually breaks things.

How did you anonymize the images? What fields have you modified? Have you regenerated UIDs?
Have you renamed the DICOM files?

I used the same Siemens software to anonymize without changing any settings between the two. Not sure which DICOM tags get deleted or re-written.

I uploaded the dataset with the other name for you to take a look.!An5lW2cr0wILgrJr3Jdi5mQZmd55pw?e=Wkiau4

Thank you,

For me, this dataset loaded correctly, too.

Maybe try to copy the files again, maybe to a folder that has shorter name.

You can also enable detailed DICOM logging (in menu: Edit / Application settings / DICOM) and check the application log after clicking “Examine” and see if there is any message related to CardiacCycle.

I think I found the culprit.

There was a comma in the folder name. Just took it out and it worked.

Thank you to all of you for helping me with this.