ParaToSPHARMMesh completed with errors on win10

Operating system:win 10
version:SlicerSALT 1.1.0-2018-10-25

I use the example data download from the web. The output of step1 and step2 are correct. but I meet an error on step3. there isn’t any more debug information about this error. is there anybody meets the same problem?
The flowing is the running information and the example data name.

debug imformation
D:/Program Files/SlicerSALT/bin/…/lib/SlicerSALT-4.9/cli-modules/ParaToSPHARMMeshCLP.exe --subdivLevel 10 --spharmDegree 15 --thetaIteration 100 --phiIteration 100 --paraOut --FinalFlip 0 C:/Users/X711/AppData/Local/Temp/SlicerSALT/GAEI_vtkMRMLModelNodeG.vtp C:/Users/X711/AppData/Local/Temp/SlicerSALT/GAEI_vtkMRMLModelNodeH.vtp D:/Program Files/SlicerSALT/data/OutData/Step3_ParaToSPHARMMesh/InputImage_pp_surf
ParaToSPHARMMesh terminated with an unknown exception.

data name
Aim 2.0. SPHARM-PDM00

Hi,

We have uploaded new nightly packages to our SlicerSALT repository.
Could you please try this one and let us know how it goes?
https://data.kitware.com/#item/5c13c83b8d777f2179ea5d1f

Thank you,
Beatriz

Hi Beatriz,

I was having the same problem. I downloaded the nightly packages using the link you posted, but the ParaToSPHARMMesh step was once again completed with errors.
I have attached the screenshot of the error (the file names do not correspond to patient data as this project does not involve any):
ParatoSpharmMesh%20Error%202

Steps SegPostProcess and GenParaMesh completed without any errors.

Thank you very much.

Dear Marcellus,

Sorry for the delay in responding. Thank you for reporting this problem. The names do not match patient data because commandline reports the names of the nodes in the Slicer MRML scene.

In order to diagnose the problem, could you please let us know the contents of the three subfolders in the output folder?

Thanks!
Bea

Dear Beatriz,

I will just chime in on the conversation as I have had the same issue since I tried using the module. I’ve attached an image from the error log showing the saved files, once the ParaToSPHARMMesh fails, as in the last step does not generate any new files whatsoever. As Marcellus mentioned, SegPostProcess and GenParaMesh runs flawlessly. Just to add, I used the available tutorial data for this example, but attempting the process with my own data leads to the same results.
6

Regards,
Oskars

Hi @Maugust and @oradzins

I see, that is weird. Oskars, does your problem also happen in Windows 10?
The problem might be coming from the module or from the ParaToSPHARMMesh executable itself. Could one of you please send the *para.vtk and the *surf.vtk files that produce the problem? I will try to diagnose on my end.

Thank you,
Bea

Dear Beatriz,
I’ve added a zip file containing the generated output data from the tutorial example I mentioned previously below (should eb available for the next 30 days):

It ran through about 20 iterations or so, just to create a quick example, but am fairly certain more iterations just prolonged the process and ran into the same error anyway.

I do indeed run windows 10 (Version 1803, OS build 17134.471 if that is of any help). Also the problem has persisted in both SlicerSalt versions 1.0.0 and 1.1.0.

Let me know if there is anything else I can help with.

Regards,
Oskars

Dear @bpaniagua,

Here are the links to the outputs from steps 1 and 2 (step 3 just produced an empty output folder):



Kind regards,
Marcellus

Hi Marcellus and Oskars

ParaToSPHARMMesh completes in Linux.
See results here:
image%20(1)

image

It seems to be a problem with the executable itself.
It is possible to do

Slicer --launch ParaToSPHARMMeshCLP in Linux, but not on windows.

$ ./SlicerSALT.exe --launch ParaToSPHARMMeshCLP
error: [C:/Program Files/SlicerSALT 1.1.0-2018-12-13/bin/…/lib/SlicerSALT-4.11/cli-modules/./ParaToSPHARMMeshCLP.exe] exit abnormally - Report the problem.

In the meantime, could you try to use the SPHARM-PDM extension in the latest Slicer release? I have been able to run it through Slicer in windows without problems.

$ ./Slicer.exe --launch ParaToSPHARMMeshCLP
PARSE ERROR:
One or more required arguments missing!

Brief USAGE:
C:\Users\beatriz.paniagua\AppData\Roaming\NA-MIC\Extensions-27498\SPHARM
-PDM\lib\Slicer-4.9\cli-modules.\P
araToSPHARMMeshCLP.exe
[–returnparameterfile
std::string]
[–processinformationaddress
std::string] [–xml] [–echo]
[–deserialize std::string]
[–serialize std::string]
[–FinalFlip ]
[–procrustesTransformationFile
std::string]
[–procrustesTransformationOutputOn
] [–regParaPoints std::string]
[–regParaPointsOn]
[–regParaTemplate std::string]
[–regParaTemplateFileOn] [–verb]
[–medialMesh] [–NoParaAlign]
[–paraOut] [–regTemplate
std::string]
[–regTemplateFileOn]
[–flipTemplate std::string]
[–flipTemplateOn] [–phiIteration
] [–thetaIteration ]
[–spharmDegree ]
[–subdivLevel ] [–]
[–version] [-h] std::string
std::string std::string

We are looking into it here: https://github.com/Kitware/SlicerSALT/issues/138

We will keep you posted.
Thank you for reporting the bug!

Bea

Operating system:win 10
version:3D Slicier 4.10.2

Hi,

I meet same problems with test data (SPHARM_Tutorial_Data_July2015)
=> Case 0: groupA_01_hippo - step 2: ParaToSPHARMMesh completed with errors

So, now I have to try Slicer or 3D-slicer in Linux, right?

Thank you,
Suji

Has there been a fix for this, i am having a similar error with ParaToSPHARMMesh completing with errors in SlicerSALT 2.2.1 on windows and Linux, and as an extension on 3Dslicer 4.10 ?

Thanks,

Rob

Hi Rob,

Have you tried the example data in our public folders?
https://data.kitware.com/#collection/586fbb7b8d777f05f44a5c7b/folder/5d5c185f85f25b11ff3e1911

Linux: I can reproduce your error message, but for the dataset above the data gets computed correctly.
Windows: We are checking and we will keep you posted.

Thank you for reporting and bringing our attention back to the problem.
Bea

Hi Bea,

I’ve been using the example data sets and still getting errors.

“/home/robl/Documents/SlicerSALT-2.2.1-linux-amd64/bin/…/lib/SlicerSALT-4.11/cli-modules/GenParaMeshCLP: error while loading shared libraries: libgfortran.so.3: cannot open shared object file: No such file or directory”

Is there maybe some prerequisites or file paths that i don’t have set that are causing the problems.

Thanks,

Rob

Thanks for reporting. I am not sure why this is happening but for sure we need to look into it further.

We will keep you posted. Hopefully we can have this fixed this week.

Updates:

There are separate bugs for the windows and linux installers involving Fortran packaging. We are working to address both. In the meantime, there is a work-around for the linux error. Installing the missing fortran library will allow SlicerSALT to run correctly.
For linux, try this terminal command:
sudo apt-get install libgfortran3

This will install the library that SlicerSALT is looking for into the path.

Thanks, that fixes the ParaToSPARMMesh problem, the function now completes. However, now the outputs crash the population viewer in v2.2.1. I had to go back to v2.0.0 to get a working version.

Rob

Could you give an some error output / description?

Opening the files in the population viewer from the SPHARM section in v2.2.1 gets this error.

" Traceback (most recent call last):
File “/home/robl/Documents/SlicerSALT-2.2.1-linux-amd64/bin/…/lib/SlicerSALT-4.11/qt-scripted-modules/ShapeAnalysisModule.py”, line 710, in onCheckableComboBoxValueChanged
outputRootname = label.text
AttributeError: ‘NoneType’ object has no attribute ‘text’ "

moving to the population view and opening the Step3_ParaToSPHARMMesh directory crashes and closes SlicerSALT and i am not sure how to get an error message from that. This happens with both the output files i solve, and your example ones.

Rob

Thanks for the info, looking into this.