Errors with GenParaMesh


Whenever I run the GenParaMesh step with my segmentation (which has successfully gone through the SegPostProcess step), it results in this error through Slicer 4.8.1, Slicer 4.10.2, and Slicer SALT 2.0.0. I realize this issue has come up before, and it was determined to be due to windows 10 (it apparently works on Linux): ParaToSPHARMMesh completed with errors on win10

Below is the message that comes each time once I cancel the seemingly infinite operation after letting it run for over a day:

GenParaMesh standard output:
Euler Number ok = 2

flag = 0 iterations performed: 524
flag = 0 iterations performed: 535
initially active: {}.
fromC[expr_] := expr /. (mant_Real)e + (expon_Integer) :> mant10^expon;

Any help is appreciated, thank you!

Thanks Yash,
Not sure what the problem is (and I think it’s quite possibly different from the ParaToSPHARM error you referenced). Could you provide a screenshot of your segmentation (e.g. using the SALT Dataimporter visualization, or simply the mesh generated with Slicer from the label file). It would be good to look at the mesh to ensure it does not have holes/handles. (A Euler number of 2 does not guarantee spherical topology, but a Euler number other than 2 guarantees non-spherical topology).

You can also run the GenParaMesh step with 0 iterations, and the tool should provide you with the initial spherical mapping. Visualizing that initial spherical parametrization is quite indicative of potential issues.


Hi Yash,

Additionally to the questions asked by Martin, what is the format of your segmentations?
Does SegPostProcess finish succesfully?


The SegPostProcess did finish successfully, but Martin is right: even though the Euler number was 2, it did not guarantee spherical topology. I went on to change my segmentation method and got everything to work.

Thank you both for your help!

Great to hear things worked!
Just curious, can you please let us know how did you change your segmentation?

Yes, at first the segmentation was of cartilage and it appeared to be rather flat, even though it passed through the SegPostProcess. To fix this, I changed the segmentation to be of cartilage and bone, allowing it to complete all steps properly, ensuring spherical geometry.