Problems with the SPHARM-PDM on Slicer-4.8.0-linux-amd64 (Command-Line Tool, the step GenParaMesh)

Hello, everyone,

I tried to utilize the software Slicer(Slicer-4.8.0-linux-amd64) and the method SPHARM-PDM to get the some SPHARM Mesh ( such as the output files *para.vtk and *SPHARM_Ellalign.vtk).

If I use the main window, and select the module through click ’ Modules – Shape Analysis Module’, and then select the input and output directories, I can run the SPDM analysis successfully.
Finally, I can obtain the 3 output folders (Step1_SegPostProcess , Step2_GenMeshPara, Step3_ParaToSPHARMMesh).

But if I try to use the SPHARM-PDM Command-Line Tool on Linux: ./Slicer --no-main-window --python-script share/Slicer-4.8/CommandLineTool/ share/Slicer-4.8/CommandLineTool/SPHARM-PDM-parameters.ini
) for the same dataset as before, I will get some errors in the step GenParaMesh like the following content:

GenParaMesh standard output:

itk::ExceptionObject (0x7ffddee49b80)
*Location: “Unknown” *
File: /home/kitware/Dashboards/Nightly/S-480-E-b/SPHARM-PDM/Libraries/Shape/Algorithms/BinaryMask3DEqualAreaParametricMeshSource.txx
Line: 97
Description: BinaryMask3DEqualAreaParametricMeshSource : Image empty

GenParaMesh completed with errors

I tried to fix this error but failed. Could you kindly guide me to solve this problem? Thank you very much!

I would appreciate any help, thanks in advance.