Pkmodeling: How to modify time between acquisitions

I am currently using the DICOM browser to import a image set with 70 time points/acquisitions that are separated by ~19 seconds, however the software appears to be interpreting the acquisitions as being separated by 10 ms (which I believe corresponds to the TR). Once the DICOM data has been loaded the file name says sorted by Imagepositionpatient+Instancenumber which may be the cause of the misreading of the acquisition time frame. I was wondering the best way to manually correct this?

@bmb777 there is currently no interface in the GUI for this, but it is easy to do:

  1. import and load the DCE series as a multivolume into Slicer using DICOM Browser. To make sure it is loaded as a multivolume, you can toggle “Advanced” view in the DICOM Browser and see something like this after you examine the dataset:

image

  1. save the loaded multivolume as a .nhdr file using “Save data” option:
    image

  2. open the .nhdr file in a text editor, you will see the following item in the header that contains time stamps for the individual temporal frames:

image

  1. update those time stamps with the proper temporal resolution (make sure timestamps are in milliseconds, since this is what PkModeling expects!), you can conveniently make that string as follows:
for i in numpy.arange(0,19000*70,19000): print("%d," % i, end='')
  1. load the updated .nhdr file into Slicer, it should now show the updated temporal resolution.

Let us know if this resolves the problem for you.

Also, if you can suggest a generic strategy how the proper temporal resolution could be populated for this dataset from the content of the existing DICOM attributes, this would be extremely helpful!

This resolves the issue, thanks. As for a strategy to correct this, I emailed the MRI technician to determine if the information needed is present in the DICOM attributes and will update this post when he responds.

1 Like