Poll: Which version of macOS do you use to run Slicer?

Hi Slicers,

We are thinking about updating the minimum supported version of macOS (most likely 10.11 “El Capitan”) but before doing so we would like to have a better idea of what you are all using to run Slicer.

Thanks for your input :smile:

  • 10.9: “Mavericks” (2013)
  • 10.10: “Yosemite” (2014)
  • 10.11: “El Capitan” (2015)
  • 10.12: “Sierra” (2016)
  • 10.13: “High Sierra” (2017)
  • 10.14: “Mojave” (2018)

0 voters


Note: I have one machine running 10.13 High Sierra, but it’s got an old GPU so it cannot run either Mojave or Slicer 4.10.x. This is because Apple isn’t supporting the new OS on the old machines. To optimize our developer resources I vote that we only support Mojave for Slicer 4.10 and beyond. People with older machines can use older versions of Slicer.

I would vote for targeting 10.13 or later. Our lab also have many Macs that are stranded on 10.13 as 10.14 does not support their Radeon GPUs (even though they are far more powerful than some integrated Intel GPUs that are supported by 10.14). With 10.14 Mojave Apple has deprecated OpenGL. In my experience, an OpenGL application on 10.14 can not set the “NSRequiresAquaSystemAppearance” to “false”. This means that OpenGL applications can not automatically take advantage of the Mojave Dark Mode. I think this reflects a difference in the Mojave layer manager. A bigger issue is that OpenGL code that works fine on 10.14 when built against the 10.13 SDK fails when built against the 10.14 SDK. This has been well documented, and you can find hacks for this with a web search. Given that OpenGL is deprecated, it is unlikely Apple will fix the OpenGL-specific bugs introduced with the 10.14 SDK. It is unfortunate that one of the worlds most valuable companies does not want to devote the resources for this open standard. Pragmatically, 10.13 appears to be the last version that treats OpenGL as a first class citizen.

Just as a reference point: here at Partners Healthcare, we have an official policy from IT that only the current macOS and two versions prior are supported.

Thanks everyone for participating.

Starting with r28019, setting CMAKE_OSX_DEPLOYMENT_TARGET to at least 10.11 is mandatory.

Thanks to @jamesobutler, following the integration of https://github.com/Slicer/Slicer/pull/4940, the minimum deployment target on macOS will be 10.13.

To support this, we will have to update the operating system on our macOS build machine from Mac OS X 10.11.6 to 10.15.

What does this mean for Slicer 4.10 extensions on macOS ?

This means that we will not publish extension update for Slicer 4.10 extension on macOS and only publish extension packages for the Slicer Preview.

When ?

We plan on initiating the operating system update tomorrow morning.

It turns that the operating system can not simply be updated. In the next few days Kitware sysadmin will proceed to a clean re-installation.

Thanks for your patience