Pre-build or Locally-build 3dSlicer under Ubuntu 16.04 does NOT start: Failed to obtain launcher executable name!

Hi everyone,

I tried to build 3dSlicer under Ubuntu 16.04, following all steps here
But, still can’t find how to run it ?

Please, anyone, have a simple instruction to make it running?


If the build was successfull:


If you just want to run and use slicer, no need to build from the source, using the binary for ubuntu is much simpler.

Hi brhoom,

Thank you for your reply.
In fact, I tried with binary with “/Slicer-4.8.1-linux-amd64”
I got " error: Failed to obtain launcher executable name !"

What do you think ?


1 Like

Try this:

  • right click on the Slicer file
  • switch to Permissions tab
  • check the “Allow execution file as program”

yes, I verified
already checked

Hi brhoom, Hi @MGM,

Let’s check that the folder contain all the expected files.

Can you run the following command and check that you get 6541 as an answer:

$ cd Slicer-4.8.1-linux-amd64
$ find . | wc -l

So you have the same error in both the binary and the build version?

there are similar related problems. Try redownloading both stable and nightly binaries and check if you still get the same error in both of them.

If it does not work, probably something wrong with your system.

@jcfr: I am not the one who has the problem. BTW, There are people who reported similar problem

The error message indicates that the following code path (associated with the function ctkAppLauncherPrivate::extractLauncherNameAndDir) is executed in the launcher:

The input to that function is obtained here using argv[0]:

I suspect that on newer Ubuntu, the path the program needs to be obtained from /proc as it is done in qapplication:

Few days ago, within Slicer itself (and not the launcher) the needed a function allowing to get the path of the application on all platforms before instantiating the application … but decided to implement a workaround in 27030

Look like the time has come to have such a function.

Hi @jcfr

yes, 6541 :ok_hand:

Hi @jcfr and @brhoom

Same issue with 4.9.0 Nightly Build

~/Slicer-4.9.0-2018-02-08-linux-amd64$ find . | wc -l
~/Slicer-4.9.0-2018-02-08-linux-amd64$ sudo apt-get update
~/Slicer-4.9.0-2018-02-08-linux-amd64$ ./Slicer
error: Failed to obtain launcher executable name !

I tried with an old release :

~/Slicer-4.8.0-linux-amd64$ find . | wc -l
~/Slicer-4.8.0-linux-amd64$ ./Slicer
error: Failed to obtain launcher executable name !

My system works fine with others software.


I finally find a solution, but only with Slicer 4.8.1 release, thanks to @brhoom
please refer to this topic, if you meet a similar issue