Problem with segment editor paint

Operating system:Windowspaint%20problem%20disable
Slicer version:4.9
Expected behavior: apply paint
Actual behavior: doesn’t work!

Hi could please help me, I start segmentation by applying the threshold, then correct it by paint and eras, but now, paint doesn’t work with me, in the middle of my segmentation I went to volume rendering and I can’t undo the volume rendering so does it affect the paint?

Volume rendering should not affect Segment editor.

Do you see any errors or warnings in the logs? (red icon in the lower-right corner)

Make sure you disabled all special options:

  • Color smudge: off
  • Editable area: Everywhere
  • Editable intensity range: off
  • Overwrite other segments: All segments

If you still have problems, try these:

  • Save the scene, restart Slicer, and load the scene and see if you can paint.
  • If still does not work, restart Slicer and load just the saved segmentation and volume and see if you can paint.
  • Install the latest nightly build and try the two steps above.

Let us know which solution worked.

Unfortunately it happens in the stable version 4.11.20200930 as well… In the middle of segment editing, the brush just cannot paint anymore…
I tried to follow your instructions and restarted, but still cannot make the paint to brush in the segment editor. It didn’t work in nightly build of 20200818 either.
Here are two “Warning” messages in “Log messages”
QLayout::addChildLayout: layout “” already has a parent
ctkSliderWidget::setSingleStep() 0 is out of bounds. 0 100 1

Greatly appreciate your help!

Can you share the scene that demonstrates this issue (upload it somewhere and post the link here)?

Would this work?

Please save the scene as a bundle (.mrb) so that the actual data files are included as well.

I see, please take a look at this one. Thank you.

All I had to do to display segmentations was to go to Data module and click on the eye icon of the segmentation node.

However, I’ve noticed that the segmentation was shifted down by about 10cm. I’m not sure how this offset could have occurred (maybe there was a transform applied on the master volume earlier?), but I removed it by editing the segmentation header file so that its geometry matches exactly the CT’s geometry. You can download the updated scene from here.

Thank you, @lassoan !
Now I noticed the shift, but when I was editing previous two segments they both looked fine on the master volume, until the 3rd one that I could not paint anymore…
I experienced “paint brush stop working” before as well, and it seems other people had similar issue…
Perhaps it was due to transformation drop-off while using segment editor?

It is hard to tell now what caused the shift. I think we fixed all the reported errors but if you can reproduce either shifting or paint strokes not appearing with latest stable or preview release then let us know.

1 Like