Paint brush behavior

Hi! So this is an issue I’ve seen a few times but still don’t understand why it’s happening. Sometimes I’m doing segmentation and even though I use paint brush on the image, I don’t see the effect on the image slice. However, I can see the changes in 3D view. Also, if I paint something at - let’s say - axial images and see no result there, I still can see changes in sagittal/coronal slices. This happens no matter how large the paint brush is. Also, I’m not changing master volume once it’s set. I’m not sure what’s going on here, unfortunately. Currently I’m running nightly build on Windows but I had this issue multiple times in the past with stable releases too. Am I missing something?

Thanks a lot for your support and great software – it is an exceptional tool in my research

Thanks for reporting this and for the thorough description! I remember seeing this once or twice, but never managed to reproduce it.

Do you have a certain way of reproducing the problem? If so, then we can fix it, but only if we know what triggers it.

i think i experienced the same problem on the segment editor module. It happened to me somethimes too. when it happened I noticed that It depends on how much zoom you use on the image. If i was to close the painter did not work, if i went back with the zoom i was able to see the painting on the image.

Working on Windows 8.1, Slicer v4.8.1 r26813

This happened to me before, but it was because the volume I was segmenting wasn’t perfectly aligned in plane of the slice viewers, and thus I was really painting on oblique slices sometimes.

Have you tried clicking the “rotate To volume plane” button in the menu beneath the pin at the top left of each slice view?

I think that the problem that i experienced was different, because at the next session i was able to segment the same set of images

The oblique view issue @Hamburgerfinger is completely reproducible and is independent from this, as in that case you see the staircase artifact, and @JanWitowski’s (and my) case there was no segment visible at all. I had to restart Slicer and it worked. It would be great if we found a way to reproduce it.

Hey thanks for the reply! Unfortunately, I haven’t found a way to reproduce it either, but there is one more interesting thing about this behavior. When I switch brush to sphere brush and paint something, it suddenly shows the sphere I just painted and all the previous non-sphere brushes. When I undo this action, both disappear. So it’s like that single sphere brush added to an image sphere brush + “history” of non-sphere brushes before.
And another one I just noticed: when I’m painting over another, visible layer with “overwrite all segments” setting, I can see that my paint brushes remove parts of the visible layer, but it doesn’t look like it’s painting over until I use sphere paint brush to trigger the “visibility”.

Hm. Maybe it’s an issue with the displayable manager. @lassoan what do you think?

I haven’t encountered these problems, so it is difficult to tell. Were you able to reproduce some of the problems?

It happened to me twice. The brush stopped leaving a trace on the slice view after extended usage. Unfortunately I don’t have a way to reproduce, hopefully @JanWitowski can help doing that.