Brush can't paint over specific area and slices

Hello everyone. I am using slicer 2 years so far. Lately I faced first time a problem that I cant resolve.
When i load a CT dataset, my brush behavior isn’t working properly as I can paint over specific areas and below them the paint is been cut. I use the segment editor module. The weird is that I have counter that problem at 3 different pc’s but not in another one, and that if I use the simple “editor” module I can paint everywhere… I can’t resolve it and cant understand what’s wrong. I tried to rotate the volume plane but nothing worked. Can someone help me?

Operating system: Windows 10
Slicer version: 4.10.2
Expected behavior: Normal paint over slices
Actual behavior: doesn’t working


This looks like a rendering issue related to display scaling (you might have changed the resolution of your screen after you have logged, you use multiple monitors, etc.). This issue has been fixed in Slicer-4.11, so please try a recent Slicer-4.11 release.

1 Like

I tried the recent 4.11 version but still the same error occurs. I tested to two different PC but still the same.The only solution I found until now, is to use simple “editor” module for painting (at 4.10 version) where I can paint over all the slices.

Great, then it means that everything works well and you just need to adjust the segmentation’s geometry.

Segmentation geometry (origin, spacing, axis directions, and extent) is determined from the first selected master volume by default, so if you later change that or transform the segmentation or the master volume, etc. then the extents may not cover the entire region where you want to draw.

You can adjust the segmentation’s geometry by clicking on the “Specify geometry” button next to the master volume selector, then choosing the volume that you want to segment as “Source geometry”, and clicking OK.