Problems with the Virtual Reality Module

Hello dear community,

I am trying to get the VR Module to run since a couple of hours now.

I tried with Quest 3 + Quest Controller.

I tried with Varjo VR3 and Vive Controllers.

I run into serious interaction problems.

Especially if I open the menu and try to select the cutting/probe tool. Using Quest 3 (in both OpenVR/OpenXR) it is not possible to select anything even though I manage to at least toggle thorugh the options.

With the Varjo XR I can select the tools with quite some hustle, but the way the interaction works (cutting plane) it is almost useless as I am forced to cut in a way that is perpendicular to my perspective.

Slicer 3D often shuts down without any error code and it is not clear why. (I reinstalled etc.)

I really like the looks of the module and to have VR integrated in Slicer 3D and being able to use all the modules and render the results in VR is really nice.

Did someone here manage to use it effectively? I have other software to render medical images and it works way better. I very much like the idea of open source however…

What Slicer version do you use?

Hi, thanks for the fast answer.

So I use the (latest) 5.6.2 Version.

Should I use an older one?

In the readme: SlicerVirtualReality/README.md at master · KitwareMedical/SlicerVirtualReality · GitHub it does not directly recommend any version, therefore I used the newest.

Is there an alternative set-up hardware and/or software wise that I should try?

The problem is that SlicerVR is undergoing a complete backend reimplementation, and I think 5.6.2 contains a VTK that does not fully support the new one (I haven’t tested VR for a while as I am waiting for the announcement that the OpenXR backend fully works, and I intend to try it then - my interest is development and not usage so I can afford such wait).

I suggest the following two options:

  • 5.4.0: It was a month after the last summer project week, when I remember that everything seemed to work again after a long period when they didn’t. Use OpenVR (install Steam and SteamVR first)
  • The latest 5.7.0: Yesterday at the Slicer Project Week meeting the Kitware developers said that other than the complex gestures (e.g. two-handed world manipulation - a feature that I consider essential but others may not) and certain minor things the OpenXR backend works well.

Hello Csaba Pinter,

thank you for the ideas, I will try them both!

Best,
Karl