SlicerVirtualReality extension for recent versions

Hi !
I am new to Slicer, but I am interested in the SlicerVirtualReality extension. I wanted to try it with the latest versions of Slicer (5.6 or 5.7), but I couldn’t find it in the extension manager, while I could find it with Slicer 5.2.2.
Has this extension not been compiled for the most recent versions ? Do I have to compile it myself if I want to try it out ?

Thanks in advance.

I believe it is broken for current stable and preview. Use it with 5.4.

The extension is actively being worked on and you should expect a working OpenVR, OpenXR as well as experimental OpenXRRemoting integration within 1 or 2 weeks. Thanks for your patience :pray:


@jcfr I tried to use the extension today, as I saw you made updates and the extension was available for Slicer5.6.1. I could install it, but I got some problems…
I have a Meta Quest 2, so that is maybe part of the reason why I got these problems, but I thought that since I could use SteamVR, it should work.
The thing is that whatever I do, whatever option I change, whatever data I try to open, I always get the same result : a blank scene, with the controllers at the top of my FOV (moving alongside my head, but also moving when I move the controller) and no model appearing (or not in my FOV).

Are you aware of this ? Or maybe the new version isn’t stable yet ?
Thanks in advance.

I don’t know if it’s still an issue, but at one point I know that you needed to have some data loaded in the Slicer scene for the VR to initialize correctly.

Unfortunately, I did have some data loaded. I haven’t tried initializing the VR before loading data, might try later…