Question on using decimated model in VMTK plugin

Hello Everyone,

I’ve decimated a model (Reduction: 0.7). The decimated model is used for Computing centerlines. After I hit Preview, the following is displayed in Python interactor

Mesh subdivision failed. Skip subdivision step.

Could someone explain what this error means? Is it ok do proceed with computing centerlines after the above-mentioned error pops up?

By default, triangles of the mesh are subdivided to make network extraction more robust. However, mesh subdivision may fail for non-manifold meshes.

If your mesh resolution is already high enough (this is the case most of the time) then skipping mesh subdivision is not a problem. However, the failure indicates that the mesh has errors, which may impact network extraction, therefore you may consider smoothing the segmentation using median method (before model exporting the segmentation to model).

1 Like

Thank you.
I couldn’t locate the module that offers smoothing using median method. Can I simply use Segment Editor and set Smoothing Factor to 1?

Median smoothing method is available in Segment Editor’s Smoothing effect.

1 Like

Thank you. Can I use the default value of 3.00 mm for Kernel size?


I’ve used Median Smoothing to smooth the segment using default value of 3.00 mm for Kernel size . The smoothed segment
was decimated (0.9 reduction) was converted to model. The decimated model is now used for Computing Centerlines.

Unfortunately, I get the same error (Mesh subdivision failed. Skip subdivision step.) for 0.9 reduction. This error doesn’t occur for 0.7 reduction now. But since the memory usage is high while computing centerlines, I want to decimate it >0.9.

Could you please have a look at the model files shared in the links provided above?

1 Like


If you had a chance to look at the files, I’d like to know if the same error appears and I would also like to ask for suggestions on how to resolve to this error.
Thanks a lot for all your support

Reducing above 0.9 doesn’t work most of the time. I am really stuck here, unfortunately.

Mesh subdivision failed. Skip subdivision step.
Input model preparation failed. It probably has surface errors.

There are several decimation methods available. Some of them work perfectly with your data set. I’m tuning things a bit and then describe which one to use and how.

Thanks a ton :slight_smile: :upside_down_face:

Hi @lassoan
May I know when I will be able to use this feature?

It is available in today’s Slicer Preview Release:

1 Like

Hi @lassoan
Thanks a lot, I really like the new module especially the relocation of endpoints for positioning on the Voronoi model, autodetect, and deletion of endpoints. In the Windows version, I could view both centerline and Voronoi model after hitting Apply. I am not able to view the Voronoi model in Linux version though.

Could you please explain a bit about how Decimation Aggressiveness woks?

I’d also like to know if the documentation of Extract Centerlines module is already available.

Parameters are explained in tool tips that appear when you hover over with the mouse and leave there for a few seconds.

Thank you.

Could you please look into this?

Thank you. I’m trying to understand the relation between Target point count and Decimation aggressiveness. From what I understand from the explanations provided in the tool tip, Target point count does the function of Reduction (a ratio, varied between 0-1; similarly what’s the range of Decimation aggressiveness) previously available in the centerline computation module i.e reduce the number of points on the surface. But I don’t clearly understand how Decimation aggressiveness

Lower values preserve mesh integrity better but it may not be possible to reduce number of points to desired level

is related to Target point count. For instance, I thought if I vary one (e.g. Target point count) the other parameter (Decimation Aggressivess) will vary as a function of the former. But this doesn’t happen.

Could you please explain this a bit?

You need to experiment a bit more to investigate the issue. For example, if you take the scene from the Linux, can you visualize the missing voronoi diagram on your windows? If that’s the case it might be related to your Linux graphics settings.

1 Like

Thank you. The problem is after using Extract Centerlines, in addition to the Voronoi model, I am not able to view the segmentation volume too (this can be seen in the snapshot posted above- the eye icon next to segmentation node is open ). The segmentation volume is visible after loading the file though, prior to centerline computation. The volume disappears after hitting Apply in Extract Centerlines. So I think the problem may not be due to the Linux graphics settings.

@lassoan Could you please look into this?

Please add a new topic to discuss this models/volume not appearing issue. Try to reproduce it without VMTK, just by loading models and adjusting transparency settings and enabling/disabling depth peeling in the 3D view.

Thanks a lot for your response. Sure , my question on Decimatin aggressivenes remains here and I have navigated the other question to new thread