Radiomics module not working?

I have been using the Radiomics module for several years now and it has worked properly. The latest version for which it still works for me is 5.4.0. In newer versions it does not work, the output is blank. I have not changed my computer platform so it is not a hardware issue. Is this a known issue, or is there something else locally I might need to address? Any help is appreciated!

Kent

Yes, it’s not currently working on all platforms (mac is broken, others might work on the new 5.6.1). Using the older release is probably the best workaround for the time being.

1 Like

Ok, thank you for the information! As long as it is not my computer . . .

Kent

It’s a problem because I can’t use Total Segmentator unless I use the newer version. So right now I don’t have a version with both radiomics and Total Segmentator both working at the same time!

I agree, I have two versions of Slicer installed because of this issue. My original comment meant that I don’t have a computer issue, it’s a software issue.

Kent

1 Like

There’s a fix for windows and linux that needs to be reviewed (I don’t have access to that repo to merge it but maybe @fedorov does?).

In the meantime, it would be great if people could be testing the fix. It should just be a matter of replacing the lines of code or the whole file:

1 Like

I’ve just merged it - hope this fixes it! Coincidentally, I also just today noticed the extension is missing from Slicer.

Thanks Andrey :+1:

The extension built on windows and linux but there was a runtime error. On mac there’s a build error so no extension is available.

Any update for Mac users? is the extension back? if not which is the latest working version of slicer that we can use to have a working radiomics plugin?

I don’t think there’s any progress on the mac version of pyradiomics. The build system needs work. Unless someone else knows off the top of their head you’ll need to test to see when there was a working version and report back if you can.

Thanks @pieper! I tried building Slicer 5.4.0 from source but I cannot install the extension… @fedorov is there a plan for a future fix for the most recent version of slicer?

It may be hard to build older slicers, but you should still be able to get the application and install extensions for released binaries at this link: https://slicer-packages.kitware.com/#collection/5f4474d0e1d8c75dfc70547e/folder/5f4474d0e1d8c75dfc705482

Thanks @pieper! Managed to download and install version 5.0.3 from the link you gave. I also downloaded the radiomics extension for this version which seems to work perfect. will stick there until a new version of the plugin is released to work with the latest version of slicer

@fedorov is there a plan for a future fix for the most recent version of slicer?

The error seems to be in pyradiomics, not in the SlicerRadiomics extension itself. I submitted an issue, but I am not sure if pyradiomics is being maintained. I suggest following up in that issue.

@fedorov is there a reason for SlicerRadiomics to build pyradiomics from source?

Latest pyradiomics (3.1.0) does have a Python whl file for macOS. pyradiomics · PyPI. This seems to indicate that it isn’t so much a problem with pyradiomics as it was possible for it to build a whl file successfully and upload to PyPI for macOS.

Therefore SlicerRadiomics could instead install from whl instead of build from source.

1 Like

That’s a great idea! I don’t remember why we are building it from source in SlicerRadiomics, but indeed I should experiment with switching to pip install. Thank you!