Rat Lungs Trouble

Operating system: Linux
Slicer version: 4.8.1
Expected behavior: I’m working with a DICOM file of rat’s lungs and according to my PI the file sizes are very large and because of that the program runs very slowly. I’ve tried to do several different techniques I’ve seen online such as cutting out certain segments using the scissors tool under the segment editor module (for some reason the ‘erase outside’ doesn’t do anything), I’ve also tried cropping the volume using the crop volume module (although it runs and creates a new save when I try to render that under the volume rendering module it doesn’t load anything) and I’ve also tried an extension called “Slicer - AirwaySegmentation” and that doesn’t result in anything either. The overall goal is to get different renderings of the lobes and if possible, the bronchi in order to calculate volumes and diameters. If there are any suggestions I would love feedback, I’m extremely new to Slicer 3D so some directions could go over my head if there isn’t enough detail. I greatly appreciate the help!
Actual behavior: N/A

To improve speed, crop the volume to the relevant region of interest and/or decrease resolution (increase “Spacing scale” parameter). After cropping, remove the original, non-cropped volume to conserve memory. Erasing segments will not make segmentation faster. Scissors effect will not modify or crop the original volume, so it will not make anything faster either.

What are the dimensions of the volume after cropping? (you can see that in Volumes module / Volume information section)

What would you like to segment in the lung? What would you like to use the segmentation for? Can you attach screenshots of how things look now and an example of what you would like to have?

I tried to crop it again yet it won’t actually save the cropped ROI. Instead it’ll make the ‘cropped volume’ and when I check it in the volume information it simply comes out as image dimensions: 0,0,0 whereas the original file comes out as 1024, 1024, 1024.

Also, how do you remove the original, non-cropped volume?

I would like to segment each section of the lung out, such as having a separate segment for each lobe along with one for the bronchi. This would be to calculate the volume of each segment and repeat this process for other lungs in the future.



I’m not sure if those images work but the first should be what the rats lungs are now and the second is an online image of what I would like them to look like.

Thank you again.

I have yet to get a reply, I have tried the crop volume several times and it hasn’t created a new volume for me. Can I please have assistance on my issue as I haven’t been able to find any help elsewhere online.


Go to the ‘Data’ module. Click right on the original dataset and choose delete.
Actually your cropped volume should also be there. If not, then something when wrong.
I suggest that you try it again, but then just use the default settings. Works fine with me.

Good luck.


Most probably you have run out of memory. Increase virtual memory/swap size may fix it.

Check the application log (X icon in the lower right corner) to check if there was any error or warning message.

Now seeing it I do believe that the computer runs out of memory. Thank you very much!