ROI registration not working

It is not possible to perform ROI registration since selection of landmarks does not work.
Did anyone find a solution to this issue?

There are several landmark registration modules available and you can also register segments (maybe you refer to that by ROI?). What would you like to achieve?

I need to superimpose two dental digital models by selecting landmarks in the palate and also including Regions of Interest around them. But as the “select landmark” tool does not work, applying radius and thus include ROI in the registration is not possible.
I am using the extension CMF and Surface registration to do that.
Is there another way?

I don’t know CMF registration features - maybe @bpaniagua can help you with these.

However, you can use simple landmark registration using “Fiducial registration wizard” module in SlicerIGT extensions.

Yes, i have actually downloaded this extension as well. However, it does not allow us to perform ROI registration, which would add regions of interest to the desired landmarks.
Thanks for all the help you can give.

Yes, “Fiducial registration wizard” module only uses the landmark point positions.

Can @bpaniagua please help then?

Is it possible to download an older version of the software?
Many published dental research mention the version 3.1 and the use of ROI registration.
Maybe the tool “select landmark” worked just fine back then.

You can download older releases from Check out the “access older releases” and “Slicer3 download” links.

What is the name of the registration module that you have trouble with?

It has actually worked!!!
The registration module is from extension “CMFreg”. Surface Registration - ROI registration.
In version 5.0 the selection of landmarks works properly and thus ROI registration.

1 Like

Do you know if there is a way a can get fiducials to follow a model when registration is performed? There are some landmarks that i need to place before performing the registration and these are both on the moving and the fixed model. But after registration the landmarks on the moving model do not follow it. Do you know if there is a way to fix that?

You may have to manually assign the landmarks to the resultant transform from the registration. You can use the Transforms module to do that.

1 Like

That solved the problem. Thank you very much.

1 Like