Segment editor crashes on loaded segments

Hi All!

I have a problem with the Segment Editor crashing. I load a dataset and a set of segment nodes that I have created in a previous session (.nrrd). This works well. But as soon as I conduct any operation on these segments in the Segment Editor, Slicer crashes and shuts down.

This does not occur if I save my segments as a labelmap, load that, and then extract the segments from it. However, this is quite tedious for me because I have some segments that overlap each otherwhich is obviously corrupted in the labelmap conversion.

I have tried this on three Windows machines with Slicer versions 4.8.1, 4.10.2, and 4.11. The issue is reproducible in all of them.

Would be grateful for any hints. Thanks a lot!

What version of Slicer was the segment .nrrd saved with?
Could you could upload your nrrd file somewhere?

Kyle! Thanks a lot - I think your question may have already solved it. The nrrd file was saved with 4.10.2. Same problem occurred over a bunch of datasets. Now I saved one with 4.11.0 - and it seems to work. Didn’t think to try and save them with different versions.

Thanks a lot! I’ll be back if it occurs again. :slight_smile:

Slicer should not be crashing with segments from 4.10.2, so there is still something wrong.
If you could provide a segmentation that causes Slicer to crash, it would be very helpful.

Yup. Fair point! Thank you for your help!

Here’s a download link that’s valid for the next 24-ish hours. Let me know if this is in any way helpful.

edit - here’s the actual link:

Unfortunately, I can’t seem to replicate the issue. The segmentation loads fine on 4.10.2, as well as the latest nightly.

Can you edit the segments?

Ah sorry, I see the crash now. I’ll debug into this issue.
Thanks for your assistance!

There seems to be a problem with the tumor extent. See line 22 in the NRRD file:
Segment1_Extent:=17 21 0 38 224 77

This isn’t a problem that I’ve seen before with saved segments.
How was the tumor segment set?
Was the NRRD edited manually?

In any case, I’ve made a pull request that should solve this issue here:

That is awesome! Yes, it is modified manually and we get rid of the tumour segment but were not aware that it’s crucial to actually delete the whole thing. Thanks so much Kyle!

The fix should be availiable in the latest 4.11 nightly.

1 Like