Segment Editor slowdown


I am experiencing extreme slowdowns when using segment editor. I downloaded a newer version and still get the problem.
I am thinking the file may be too large, so would removing nodes of data help at all?
Is there a way to remove the automatic update checkbox in the fill in the slices function? that may be another issue.
Or is it possible for a bug to be going on?

Any help would be appreciated!

We’ve checked this with Valeria and found out that the problem was mainly due to having too large (too high resolution) segmentation and 3D representation update for such large volume took too long time.

By performing these 3 steps, update after each editing operation reduced from about 10 seconds to a fraction of a second:

  • Decrease segment resolution by 2x (resulting in reducing number of voxels by 8x): export segmentation to labelmap, resample using Crop volume, import labelmap to new segmentation
  • Disable 3D smoothing (set smoothing factor to 0)
  • Make 3D model simpler by smoothing the segment (using Smoothing effect, median method, kernel size of 9 voxels)
1 Like