Segmentation operation takes too long for virtual reality

Hi, I’m having the same issue on my end where virtual reality screen goes into a loading screen when the subtract logical operator is activated to remove the overlapping segmentation (the rendered model from imaging and the controller model). Smoothing has been turned off and the update rate in Virtual Reality module has been set to the the fastest speed, and yet the loading screen still appears for 3s before the updated model is shown, about the same duration as before the parameters were changed. Could you give me some advice as to how to avoid this? I would like to see the pre-rendered model in virtual reality even when it’s rendering slowly, but a shorter rendering time would be ideal.

Running on slicer 4.10.2!

If model generation takes 3 seconds without smoothing then most probably you have complex segments. Certain operations, such as thresholding tend to generate very complex segments because it creates thousands of tiny speckles and uneven edges. You can remove these by using the Smoothing effect / Median method before creating 3D models.

You may also improve overall performance by cropping and/or downsampling the master volume.

Also, try recent preview versions of Slicer, there may have been performance improvements that are relevant for you.

In the future, we might consider off-loading 3D model generation to a background thread to improve responsiveness of the application, but since updates are already quite fast (when surface smoothing is disabled), this task does not have very high priority.


4 posts were split to a new topic: Segment resolution changes after subtraction