Segmentations translocating upon loading of saved data

Hi all!

I’ve been trying to really get going with 3D slicer for a while now and I can’t seem to figure out a resolution to this issue. I am currently working on the segmentation of skink skulls. When I load saved data, what is supposed to be located at the back of the skull is found at the front. I have toyed around with changing the way I save things, but I can’t seem to figure out how to properly save the data for it to be correctly loaded the next time I work on it. Has anyone seen this issue/know of a resolution?

Thank you!

What format your original input files are loaded from? DICOM, nrrd, nii, stl, obj, ply,…?

What file format the segmentation is saved into?

After saving, do you load the saved scene (.mrml or .mrb file) or select a few data files and load just those?

What Slicer version do you use?

Can you share the application logs of both saving the segmentation and loading the segmentation? (application logs are available in menu: Help / Report a bug)

Thank you for the response! I am importing .tif files. I saved the segmentation as a .nrrd file. I load in the scene as a .mrml file and I also load in the segmentation and .tif files that were found in the saved data. I am currently using 3D Slicer 4.11.20210226.

This is the application log after saving

This is the application log after loading

Looks like your image is coming in as a tiff stack. You will probably find it easier if you use the ImageStacks module of SlicerMorph extension.

If the specimen is reversed to what you are expecting to find, you can click the reverse option, and reimport the stack.

Once you successfully import your stack (with correct orientation and image spacing) before segmenting it, you really need to save it as NRRD volume, so that next time you don’t have to repeat the import process. You can do CTRL + S to open the Save As dialog box, or if you installed the SlicerMorph, right click on the imported volume in the Data module and choose Export As and save it as NRRD.

1 Like

Thank you! I will try this and reply with how it worked for me.