Sequence registration module

Has the sequence registration module been renamed or something? It doesn’t come up after installing the latest nightly in windows or Mac,
It was usually under sequences; Other 3 categories are there (crop volume sequences, sequence browser and sequences ) but not sequence registration. I 've installed sequences and 4 D elastix.

Thanks a lot

You should be able to see in the Python Interactor within Slicer that the SequenceRegistration module is failing to import (see failing test). This is because the extension hasn’t been updated to work with Python3 which the Slicer nightly now uses.

You can try installing it using Slicer 4.10.2 which still uses Python2.

Or it would be welcomed if you could submit a PR to SlicerSequenceRegistration with updates that will make it Python 2/3 compatible.

Thanks @Jainey for reporting and @jamesobutler for investigating. I’ve pushed a fix, please update SequenceRegistration tomorrow and let me know if you still experience problems.

1 Like

Thank you very much @lassoan and @jamesobutler. I will update this, hopefully this solves the problem
Sorry Just tried updating still not working

What error are you getting? Check Help->Report A Bug or look for any output in the python interactor.