Skull segmentation issues (no Erase, Scissors, Islands functions working)

Dear All,
I hope you are well.

I am looking for some help to achieve the segmentation of a skull based on CT data (CBCT) for dentistry purposes.
For some reasons that I cannot explain, I am not able to get rid of the all the noises and some areas (vertebras, mandibla, ribs) through Islands, Erase or Scissors functions. Any attempt of modification trough any of those methods does not appear on my model. Even any change on the smoothing factor does not apply to it.
Can anyone help with this ?
Is there a possibility that a protection on the model and some data are missing from the CT data (CBCT) ?
Thank you so much !

Use the default masking settings to make sure that masking does not interfere with your intended modifications:

It works perfectly !! Thank you so much @lassoan !!! :slight_smile:

1 Like

Dear All,
I come back to you because during the segmentation process, i am unable to erase some parts from my model. It is not possible for me to take off all the remaining teeth from the absent mandible. Both Scissors and Erase function do not work. On the CT images, it shows like if they are within the Threshold range but no Threshold change modifies it.
Can you help with that, please ? I would like to remove the lower teeth.

Thank you all !

I again suspect the masking options. Make sure it is Everywhere and Overwrite all.

Thank you for your answer.
I checked the masking options and nothing changed. Could it be something else ?

Might you have a model in the scene in addition to the segmentation? Segmentation tools will edit the current segment, but will have no effect on a model. Sometimes a model has the exact same appearance in the 3D view as a segment (usually because you generated the model by exporting it from the segmentation, so it matches perfectly in color and location), but would hide any subtractive editing. The segment would be edited, but you would see no change in the 3D view because the changes are behind the opaque surface of the model.

1 Like

Would support that. Please have a look in “Data”
, maybe post the “Data” content of that scene. There must be something in the scene that overlays your editing.

Thank you @rbumm @mikebind
Here is the “Data” content. I have tried to (un)mask different segments and i am still unable to erase the mandible teeth.
Thank you so much for your help.

It appears that you have three segmentations which are all named “Segmentation”. I would suggest changing the names of each of them to be distinct (you can do this by double clicking on the name in the Data module and entering a new name). One possible source of your problem is that you have been editing only one of the segmentations, and looking for effects on the other one, which is unaffected by edits to the first. In the Segment Editor module, make sure the segmentation you are editing is the same as the one you are viewing. It would also help you keep track of things if you change the color of each segment by double-clicking on the color square and selecting a new color. That will help to clarify which elements you are currently viewing and editing.

Correct Mike.

@Kevin_Wendo in the image you provide

you are actually viewing the segmentation that is marked with red arrows here. See also both marked eye symbols, they indicate what is visible in the scene. Change the name of that “Segmentation” (double click on it to rename) to “Segmentation_final”. Then select “Segmentation_final” in the Segment Editor and make your desired changes.

1 Like

Dear All,
Thank you for your recommandations, it worked I was able to erase the areas i needed too!.
Quick question : I switched the “Editable area” to “Inside segments” and it worked too, can you explain me why ?
Thank you very much for your support!

The masking settings control where segment editing tools are allowed to make changes. If you choose to have the “Editable area” be “Inside segments” then the selected editing tool will only be able to make changes to voxels which are already inside existing segments. This works fine for subtractive tools like the “Eraser” because it only makes sense to erase parts of existing segments. On the other hand, if you only had one existing segment and you tried to add to it using the Paint tool, but had the editable area as “Inside segments”, it would be impossible to paint new areas to add because all voxels outside of your single existing segment are outside your “editable area”.

Alright Thank you very much Mike ! :slight_smile:

1 Like